summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCrankySupertoon2020-04-13 10:58:01 -0400
committerCrankySupertoon2020-04-13 10:58:01 -0400
commit5e53757257f7a1390ff198cbde1acb85981b5bad (patch)
tree7623f12e69576539b9cd4a91ee3a0969b9e533e5
downloadaur-5e53757257f7a1390ff198cbde1acb85981b5bad.tar.gz
GDlauncher 4 AUR - 0.0.2
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD51
-rw-r--r--gdlauncher.desktop9
-rw-r--r--gdlauncher.install13
4 files changed, 94 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6ec10aa4f19d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = gdlauncher
+ pkgdesc = GDLauncher is simple, yet powerful Minecraft custom launcher with a strong focus on the user experience
+ pkgver = 0.0.2
+ pkgrel = 1
+ url = https://gdevs.io
+ install = gdlauncher.install
+ arch = x86_64
+ license = GPL3
+ depends = libnotify
+ depends = libxss
+ depends = libxtst
+ depends = libindicator-gtk3
+ depends = libappindicator-gtk3
+ depends = rust
+ source_x86_64 = gdlauncher.desktop
+ source_x86_64 = GDLauncher-linux-setup.AppImage::https://github.com/gorilla-devs/GDLauncher-Releases/releases/download/v0.0.2/GDLauncher-linux-setup.AppImage
+ sha256sums_x86_64 = 9b512c4b92ee7405e3774aa66348636738e30866a8227937578aaa67cfc8ed51
+ sha256sums_x86_64 = b10f7d115d7aaaaff128c03b9f679cbd968a61c61a19d228cfd131ba7c658ab7
+
+pkgname = gdlauncher
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c78f760a2a41
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Cranky Supertoon <crankysupertoon@gmail.com>
+# Contributor: S Stewart <tda@null.net>
+# Special thanks to RyanTheAllmighty for making hyper-appimage
+pkgname="gdlauncher"
+pkgver="0.0.2"
+pkgrel=1
+arch=('x86_64')
+pkgdesc="GDLauncher is simple, yet powerful Minecraft custom launcher with a strong focus on the user experience"
+url="https://gdevs.io"
+license=('GPL3')
+install="gdlauncher.install"
+depends=('libnotify' 'libxss' 'libxtst' 'libindicator-gtk3' 'libappindicator-gtk3' 'rust')
+sha256sums_x86_64=('9b512c4b92ee7405e3774aa66348636738e30866a8227937578aaa67cfc8ed51'
+ 'b10f7d115d7aaaaff128c03b9f679cbd968a61c61a19d228cfd131ba7c658ab7')
+source_x86_64=(
+ "gdlauncher.desktop"
+ "GDLauncher-linux-setup.AppImage::https://github.com/gorilla-devs/GDLauncher-Releases/releases/download/v${pkgver}/GDLauncher-linux-setup.AppImage"
+)
+
+prepare() {
+ # mark as executable
+ chmod +x "${srcdir}/GDLauncher-linux-setup.AppImage"
+ # extract (didn't know this was possible)
+ "${srcdir}/GDLauncher-linux-setup.AppImage" --appimage-extract
+ # executable isnt needed now
+ chmod -x "${srcdir}/GDLauncher-linux-setup.AppImage"
+}
+
+package() {
+ # install the main files.
+ install -d -m755 "${pkgdir}/opt/${pkgname}"
+ cp -Rr "${srcdir}/squashfs-root/"* "${pkgdir}/opt/${pkgname}"
+
+ # desktop entry
+ install -D -m644 "${srcdir}/gdlauncher.desktop" "${pkgdir}/usr/share/applications/gdlauncher.desktop"
+
+ # install the icons
+ install -d -m755 "${pkgdir}/usr/share/icons/hicolor"
+ cp -Rr "${srcdir}/squashfs-root/usr/share/icons/hicolor/" "${pkgdir}/usr/share/icons/hicolor"
+
+ # fix file permissions - all files as 644 - directories as 755
+ find "${pkgdir}/"{opt,usr} -type d -exec chmod 755 {} \;
+ find "${pkgdir}/"{opt,usr} -type f -exec chmod 644 {} \;
+
+ # make sure the main binary has the right permissions
+ chmod +x "${pkgdir}/opt/${pkgname}/gdlauncher"
+
+ # link the binary
+ install -d -m755 "${pkgdir}/usr/bin"
+ ln -sr "${pkgdir}/opt/${pkgname}/gdlauncher" "${pkgdir}/usr/bin/gdlauncher"
+}
diff --git a/gdlauncher.desktop b/gdlauncher.desktop
new file mode 100644
index 000000000000..71972167cb34
--- /dev/null
+++ b/gdlauncher.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=GDLauncher
+Comment=GDLauncher is simple, yet powerful Minecraft custom launcher with a strong focus on the user experience
+Exec=/opt/gdlauncher/gdlauncher
+Terminal=false
+Type=Application
+Icon=gdlauncher
+StartupWMClass=GDLauncher
+Categories=Game;
diff --git a/gdlauncher.install b/gdlauncher.install
new file mode 100644
index 000000000000..f39ea2214987
--- /dev/null
+++ b/gdlauncher.install
@@ -0,0 +1,13 @@
+post_install() {
+ xdg-icon-resource forceupdate
+ xdg-desktop-menu forceupdate
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ xdg-icon-resource forceupdate
+ xdg-desktop-menu forceupdate
+} \ No newline at end of file