summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorS Stewart2019-08-08 23:35:08 -0500
committerS Stewart2019-08-08 23:35:08 -0500
commit16cdb4dee89c556152b50ce4f92eea9cd1fbd59a (patch)
tree062bb8be849310a3ef00db4a1643d238ac23f90a
downloadaur-16cdb4dee89c556152b50ce4f92eea9cd1fbd59a.tar.gz
init
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD48
-rw-r--r--README.md15
-rw-r--r--gdlauncher-appimage.install13
-rw-r--r--gdlauncher.desktop9
5 files changed, 102 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ba5a14998640
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = gdlauncher-appimage
+ pkgdesc = Modded Minecraft launcher built with Electron/React
+ pkgver = v0.11.15
+ pkgrel = 1
+ url = https://gdevs.io
+ install = gdlauncher-appimage.install
+ arch = x86_64
+ license = MIT
+ depends = libnotify
+ depends = libxss
+ depends = libxtst
+ depends = gconf
+ depends = libindicator
+ depends = libappindicator
+
+pkgname = gdlauncher-appimage
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8bb57cb6e240
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: S Stewart <tda@lmao.tf>
+# Special thanks to RyanTheAllmighty for making hyper-appimage
+pkgname="gdlauncher-appimage"
+pkgver="v0.11.15"
+pkgrel=1
+arch=('x86_64')
+pkgdesc="Modded Minecraft launcher built with Electron/React"
+url="https://gdevs.io"
+license=('MIT')
+install="gdlauncher-appimage.install"
+depends=('libnotify' 'libxss' 'libxtst' 'gconf' 'libindicator' 'libappindicator')
+
+_source_x86_64=(
+ "GDLauncher-linux-setup.AppImage::https://github.com/gorilla-devs/GDLauncher/releases/download/${pkgver}/GDLauncher-linux-setup.AppImage"
+)
+
+prepare() {
+ # mark as executable
+ chmod +x "${srcdir}/GDLauncher-linux-setup.AppImage"
+ # extract (didn't know this was possible)
+ "${srcdir}/GDLauncher-linux-setup.AppImage" --appimage-extract
+ # executable isnt needed now
+ chmod -x "${srcdir}/GDLauncher-linux-setup.AppImage"
+}
+
+package() {
+ # install the main files.
+ install -d -m755 "${pkgdir}/opt/${pkgname}"
+ cp -Rr "${srcdir}/squashfs-root/app/"* "${pkgdir}/opt/${pkgname}"
+
+ # desktop entry
+ install -D -m644 "${srcdir}/gdlauncher.desktop" "${pkgdir}/usr/share/applications/gdlauncher.desktop"
+
+ # install the icons
+ install -d -m755 "${pkgdir}/usr/share/icons/hicolor"
+ cp -Rr "${srcdir}/squashfs-root/usr/share/icons/hicolor/" "${pkgdir}/usr/share/icons/hicolor"
+
+ # fix file permissions - all files as 644 - directories as 755
+ find "${pkgdir}/"{opt,usr} -type d -exec chmod 755 {} \;
+ find "${pkgdir}/"{opt,usr} -type f -exec chmod 644 {} \;
+
+ # make sure the main binary has the right permissions
+ chmod +x "${pkgdir}/opt/${pkgname}/gdlauncher"
+
+ # link the binary
+ install -d -m755 "${pkgdir}/usr/bin"
+ ln -sr "${pkgdir}/opt/${pkgname}/gdlauncher" "${pkgdir}/usr/bin/gdlauncher"
+} \ No newline at end of file
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..302de32808c8
--- /dev/null
+++ b/README.md
@@ -0,0 +1,15 @@
+# gdlauncher-appimage
+AUR package for [GDLauncher](https://gdevs.io)
+
+Based off [hyper-appimage](https://aur.archlinux.org/packages/hyper-appimage).
+
+## Why does this exist?
+One day I decided to make this package. I was bored. No other reason :)
+
+## How does this work?
+I didn't even know this until I created the package, but if you run a AppImage with `--appimage-extract` it will extract all its contents into a `squashfs-root` folder.
+
+From there, we can move the folder's contents into somewhere like `/opt/gdlauncher` and point a .desktop file to the executable, and we've just installed a appimage on our system!
+
+## License
+MIT (like GDLauncher itself) \ No newline at end of file
diff --git a/gdlauncher-appimage.install b/gdlauncher-appimage.install
new file mode 100644
index 000000000000..f39ea2214987
--- /dev/null
+++ b/gdlauncher-appimage.install
@@ -0,0 +1,13 @@
+post_install() {
+ xdg-icon-resource forceupdate
+ xdg-desktop-menu forceupdate
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ xdg-icon-resource forceupdate
+ xdg-desktop-menu forceupdate
+} \ No newline at end of file
diff --git a/gdlauncher.desktop b/gdlauncher.desktop
new file mode 100644
index 000000000000..c8610a7365f2
--- /dev/null
+++ b/gdlauncher.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=GDLauncher
+Comment=GDLauncher is simple, yet powerful Minecraft custom launcher with a strong focus on the user experience
+Exec=/opt/gdlauncher-appimage/gdlauncher
+Terminal=false
+Type=Application
+Icon=gdlauncher
+StartupWMClass=GDLauncher
+Categories=Game;