summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorS Stewart2019-10-18 16:47:42 -0500
committerS Stewart2019-10-18 16:47:42 -0500
commit2427eaf312bd45225182480f9f52286a97bd00a5 (patch)
treeaccf8375a757d4c4416c1004bc2716525bf08102
parent7eba90d6a44b3ab079d03f169ea8fcc60da1a53f (diff)
downloadaur-2427eaf312bd45225182480f9f52286a97bd00a5.tar.gz
bump version, i think the package works now
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD18
3 files changed, 18 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d4ef0235b7cb..84c94475a0be 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gdlauncher-appimage
pkgdesc = Modded Minecraft launcher built with Electron/React
- pkgver = v0.12.1
- pkgrel = 2
+ pkgver = v0.12.2
+ pkgrel = 1
url = https://gdevs.io
install = gdlauncher-appimage.install
arch = x86_64
@@ -12,8 +12,10 @@ pkgbase = gdlauncher-appimage
depends = gconf
depends = libindicator
depends = libappindicator
- source = gdlauncher.desktop
- md5sums = 63b1ca5aad86bf11fefba7252327e646
+ source_x86_64 = gdlauncher.desktop
+ source_x86_64 = GDLauncher-linux-setup.AppImage::https://github.com/gorilla-devs/GDLauncher/releases/download/v0.12.2/GDLauncher-linux-setup.AppImage
+ md5sums_x86_64 = 310ff29d9c622367e31b989610a47617
+ md5sums_x86_64 = b4963c40ec5b55ab618a5f4505431a3f
pkgname = gdlauncher-appimage
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..5b8724ee09d6
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+GDLauncher-linux-setup.AppImage
+pkg/
+src/
+*.tar.xz \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 3299195d9bb3..ce42424cdb73 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: S Stewart <tda@lmao.tf>
# Special thanks to RyanTheAllmighty for making hyper-appimage
pkgname="gdlauncher-appimage"
-pkgver="v0.12.1"
-pkgrel=2
+pkgver="v0.12.2"
+pkgrel=1
arch=('x86_64')
pkgdesc="Modded Minecraft launcher built with Electron/React"
url="https://gdevs.io"
@@ -10,16 +10,14 @@ license=('MIT')
install="gdlauncher-appimage.install"
depends=('libnotify' 'libxss' 'libxtst' 'gconf' 'libindicator' 'libappindicator')
-_source_x86_64=(
+source_x86_64=(
+ "gdlauncher.desktop"
"GDLauncher-linux-setup.AppImage::https://github.com/gorilla-devs/GDLauncher/releases/download/${pkgver}/GDLauncher-linux-setup.AppImage"
)
-md5sums=(
- "63b1ca5aad86bf11fefba7252327e646"
-)
-
-source=(
- "gdlauncher.desktop"
+md5sums_x86_64=(
+ "310ff29d9c622367e31b989610a47617"
+ "b4963c40ec5b55ab618a5f4505431a3f"
)
prepare() {
@@ -34,7 +32,7 @@ prepare() {
package() {
# install the main files.
install -d -m755 "${pkgdir}/opt/${pkgname}"
- cp -Rr "${srcdir}/squashfs-root/app/"* "${pkgdir}/opt/${pkgname}"
+ cp -Rr "${srcdir}/squashfs-root/"* "${pkgdir}/opt/${pkgname}"
# desktop entry
install -D -m644 "${srcdir}/gdlauncher.desktop" "${pkgdir}/usr/share/applications/gdlauncher.desktop"