summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortilda2021-06-18 23:38:12 -0500
committertilda2021-06-18 23:38:12 -0500
commit861b3a45dddf77ea3b1bb3dc96df2123bf0822d4 (patch)
treef01c51b8184c0a118cf0501debf1093f52f680bc
parentafb348c5ab0e556c950f5b64c4c95ee43f5afa85 (diff)
downloadaur-861b3a45dddf77ea3b1bb3dc96df2123bf0822d4.tar.gz
1.1.10 (ty huantian)
-rw-r--r--.SRCINFO13
-rwxr-xr-x[-rw-r--r--]PKGBUILD20
2 files changed, 18 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index acbeea353e89..72a65054f0d4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,23 @@
pkgbase = gdlauncher-bin
pkgdesc = GDLauncher is simple, yet powerful Minecraft custom launcher with a strong focus on the user experience
- pkgver = 1.1.8
- pkgrel = 2
+ pkgver = 1.1.10
+ pkgrel = 1
url = https://gdevs.io
arch = x86_64
license = GPL3
makedepends = gendesk
- makedepends = wget
depends = libnotify
depends = libxss
depends = libxtst
depends = libindicator-gtk3
depends = libappindicator-gtk3
+ provides = gdlauncher
conflicts = gdlauncher-appimage
conflicts = gdlauncher
conflicts = gdlauncher-git
- source_x86_64 = GDLauncher-1.1.8.zip::https://github.com/gorilla-devs/GDLauncher/releases/download/v1.1.8/GDLauncher-linux-setup.zip
+ source_x86_64 = GDLauncher-1.1.10.zip::https://github.com/gorilla-devs/GDLauncher/releases/download/v1.1.10/GDLauncher-linux-setup.zip
source_x86_64 = https://github.com/gorilla-devs/GDLauncher/raw/master/public/icon.png
- md5sums_x86_64 = SKIP
- md5sums_x86_64 = SKIP
+ md5sums_x86_64 = 4c98cd4ade613f5d03b4fc1d3292852f
+ md5sums_x86_64 = af0ce1364e34f49af3793bf8193c5369
pkgname = gdlauncher-bin
-
diff --git a/PKGBUILD b/PKGBUILD
index c719e340c9ed..d016097d60b0 100644..100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,19 +3,22 @@
# Special thanks to RyanTheAllmighty for making hyper-appimage
pkgname="gdlauncher-bin"
_pkgname="gdlauncher"
-pkgver="1.1.8"
-pkgrel=2
+pkgver="1.1.10"
+pkgrel=1
arch=('x86_64')
pkgdesc="GDLauncher is simple, yet powerful Minecraft custom launcher with a strong focus on the user experience"
url="https://gdevs.io"
license=('GPL3')
-makedepends=('gendesk' 'wget')
+makedepends=('gendesk')
depends=('libnotify' 'libxss' 'libxtst' 'libindicator-gtk3' 'libappindicator-gtk3')
+provides=('gdlauncher')
conflicts=('gdlauncher-appimage' 'gdlauncher' 'gdlauncher-git')
source_x86_64=(
- "GDLauncher-${pkgver}.zip::https://github.com/gorilla-devs/GDLauncher/releases/download/v${pkgver}/GDLauncher-linux-setup.zip" "https://github.com/gorilla-devs/GDLauncher/raw/master/public/icon.png")
-
-md5sums_x86_64=('SKIP' 'SKIP')
+ "GDLauncher-${pkgver}.zip::https://github.com/gorilla-devs/GDLauncher/releases/download/v${pkgver}/GDLauncher-linux-setup.zip"
+ "https://github.com/gorilla-devs/GDLauncher/raw/master/public/icon.png")
+md5sums_x86_64=(
+ '4c98cd4ade613f5d03b4fc1d3292852f'
+ 'af0ce1364e34f49af3793bf8193c5369')
prepare() {
# Generate .desktop
@@ -26,14 +29,15 @@ prepare() {
package() {
# install the main files.
install -d -m755 "${pkgdir}/opt/${pkgname}"
- cp -Rr "${srcdir}/"* "${pkgdir}/opt/${pkgname}"
+ cp -r "${srcdir}/"* "${pkgdir}/opt/${pkgname}/"
+ rm "${pkgdir}/opt/${pkgname}/"{icon.png,GDLauncher-${pkgver}.zip} # remove symlinked source files
# desktop entry
install -D -m644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
# install the icon
install -d -m755 "${pkgdir}/usr/share/icons"
- cp -Rr "${srcdir}/icon.png" "${pkgdir}/usr/share/icons/${pkgname}.png"
+ cp -L "${srcdir}/icon.png" "${pkgdir}/usr/share/icons/${pkgname}.png"
# fix file permissions - all files as 644 - directories as 755
find "${pkgdir}/"{opt,usr} -type d -exec chmod 755 {} \;