summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhuantian2021-11-05 18:17:45 -0700
committerhuantian2021-11-05 18:17:45 -0700
commitd84b704db08f16492e2ae595a3a8373b3f4496fd (patch)
tree1762473ee2f6cc7eac7eb0bf91d388c9fb0db2b8
parent089fe9747e84b21cd5721ecdad5b67811c629bbb (diff)
downloadaur-d84b704db08f16492e2ae595a3a8373b3f4496fd.tar.gz
v1.1.15
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore3
-rwxr-xr-xPKGBUILD40
3 files changed, 18 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 043196be0dbc..5d98bfedc8e2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = gdlauncher-bin
pkgdesc = GDLauncher is simple, yet powerful Minecraft custom launcher with a strong focus on the user experience
- pkgver = 1.1.14
+ pkgver = 1.1.15
pkgrel = 1
url = https://gdevs.io
arch = x86_64
license = GPL3
- makedepends = gendesk
- makedepends = imagemagick
+ makedepends = tar
+ makedepends = xz
depends = libnotify
depends = libxss
depends = libxtst
@@ -14,12 +14,12 @@ pkgbase = gdlauncher-bin
depends = libappindicator-gtk3
provides = gdlauncher
conflicts = gdlauncher
+ conflicts = gdlauncher-beta
+ conflicts = gdlauncher-beta-bin
conflicts = gdlauncher-appimage
conflicts = gdlauncher-git
conflicts = gdlauncher-classic
- source_x86_64 = GDLauncher-1.1.14.zip::https://github.com/gorilla-devs/GDLauncher/releases/download/v1.1.14/GDLauncher-linux-setup.zip
- source_x86_64 = https://github.com/gorilla-devs/GDLauncher/raw/master/public/icon.png
- md5sums_x86_64 = 332fd5cc4172a5eeb1c849781f6b38e7
- md5sums_x86_64 = af0ce1364e34f49af3793bf8193c5369
+ source_x86_64 = GDLauncher-1.1.15.deb::https://github.com/gorilla-devs/GDLauncher/releases/download/v1.1.15/GDLauncher-linux-setup.deb
+ md5sums_x86_64 = 686a94726312d6579d0d961b84543111
pkgname = gdlauncher-bin
diff --git a/.gitignore b/.gitignore
index e89d1bf31d0f..f2f39317e0b5 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,6 +1,5 @@
-GDLauncher-*.zip
+GDLauncher-*.deb
gdlauncher-bin-*-x86_64.pkg.tar.zst
-icon.png
.directory
pkg
src
diff --git a/PKGBUILD b/PKGBUILD
index 0be6c9a0af9e..bfeedf20667c 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,51 +3,31 @@
# Special thanks to RyanTheAllmighty for making hyper-appimage
pkgname="gdlauncher-bin"
_pkgname="gdlauncher"
-pkgver="1.1.14"
+pkgver="1.1.15"
pkgrel=1
arch=('x86_64')
pkgdesc="GDLauncher is simple, yet powerful Minecraft custom launcher with a strong focus on the user experience"
url="https://gdevs.io"
license=('GPL3')
-makedepends=('gendesk' 'imagemagick')
+makedepends=('tar' 'xz')
depends=('libnotify' 'libxss' 'libxtst' 'libindicator-gtk3' 'libappindicator-gtk3')
provides=('gdlauncher')
-conflicts=('gdlauncher' 'gdlauncher-appimage' 'gdlauncher-git' 'gdlauncher-classic')
-source_x86_64=("GDLauncher-${pkgver}.zip::https://github.com/gorilla-devs/GDLauncher/releases/download/v${pkgver}/GDLauncher-linux-setup.zip"
- "https://github.com/gorilla-devs/GDLauncher/raw/master/public/icon.png")
-md5sums_x86_64=('332fd5cc4172a5eeb1c849781f6b38e7'
- 'af0ce1364e34f49af3793bf8193c5369')
-icon_sizes=(48 128 256 1024)
-
-prepare() {
- # Generate .desktop
- gendesk --pkgname "GDLauncher" --pkgdesc "${pkgdesc}" --icon ${_pkgname} --exec "/usr/bin/${_pkgname}" --categories "Application;Game" -n -f
-}
+conflicts=('gdlauncher' 'gdlauncher-beta' 'gdlauncher-beta-bin' 'gdlauncher-appimage' 'gdlauncher-git' 'gdlauncher-classic')
+source_x86_64=("GDLauncher-${pkgver}.deb::https://github.com/gorilla-devs/GDLauncher/releases/download/v${pkgver}/GDLauncher-linux-setup.deb")
+md5sums_x86_64=('686a94726312d6579d0d961b84543111')
package() {
- # install the main files.
- install -d -m755 "${pkgdir}/opt/${pkgname}/"
- cp -r "${srcdir}/"* "${pkgdir}/opt/${pkgname}/"
- rm "${pkgdir}/opt/${pkgname}/"{icon*.png,GDLauncher-${pkgver}.zip,GDLauncher.desktop} # remove symlinked source files
-
- # desktop entry
- install -d -m755 "${pkgdir}/usr/share/applications/"
- install -D -m644 "${srcdir}/GDLauncher.desktop" "${pkgdir}/usr/share/applications/GDlauncher.desktop"
-
- # install the icons
- for size in "${icon_sizes[@]}"; do
- install -d -m755 "${pkgdir}/usr/share/icons/hicolor/${size}x${size}/apps/"
- convert "${srcdir}/icon.png" -resize "${size}x${size}" "${pkgdir}/usr/share/icons/hicolor/${size}x${size}/apps/${_pkgname}.png"
- done
+ # Extract data folder from .deb archive
+ tar xf "${srcdir}/data.tar.xz" --directory=$pkgdir
# fix file permissions - all files as 644 - directories as 755
find "${pkgdir}/"{opt,usr} -type d -exec chmod 755 {} \;
find "${pkgdir}/"{opt,usr} -type f -exec chmod 644 {} \;
- # make sure the main binary has the right permissions
- chmod +x "${pkgdir}/opt/${pkgname}/${_pkgname}"
+ # make sure the main and 7za binary have the right permissions
+ chmod a+x "${pkgdir}/opt/GDLauncher/"{${_pkgname},7za}
# link the binary
install -d -m755 "${pkgdir}/usr/bin/"
- ln -sr "${pkgdir}/opt/${pkgname}/${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
+ ln -sr "${pkgdir}/opt/GDLauncher/${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
}