summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Lau2018-09-20 10:42:29 +0200
committerSebastian Lau2018-09-20 10:42:29 +0200
commit047472c6ee248b420a57e6d19ab8c0547b204c68 (patch)
treee31a7c8bf2cee47500f9abe512fca6f8c6e92d37
parentbf4926115be030c454b96eb4fdd0a2c6b9440337 (diff)
downloadaur-047472c6ee248b420a57e6d19ab8c0547b204c68.tar.gz
UPD to 3.30.0
-rw-r--r--0003-autogoo-make-udev-rules-dir-configurable.patch63
-rw-r--r--PKGBUILD9
2 files changed, 70 insertions, 2 deletions
diff --git a/0003-autogoo-make-udev-rules-dir-configurable.patch b/0003-autogoo-make-udev-rules-dir-configurable.patch
new file mode 100644
index 000000000000..1032fc1126c9
--- /dev/null
+++ b/0003-autogoo-make-udev-rules-dir-configurable.patch
@@ -0,0 +1,63 @@
+diff --git a/Makefile.am b/Makefile.am
+index 1b710098635d9d05f6821746571198d28ecea44b..7896f59daf351927e01ce8d895bb7eba629d640b 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -30,4 +30,4 @@ EXTRA_DIST = \
+ DISTCLEANFILES = \
+ $(NULL)
+
+-AM_DISTCHECK_CONFIGURE_FLAGS = --enable-split-authentication --enable-introspection --without-systemdsystemunitdir
++AM_DISTCHECK_CONFIGURE_FLAGS = --enable-split-authentication --enable-introspection --without-systemdsystemunitdir --without-udevdir
+diff --git a/configure.ac b/configure.ac
+index 1a25c80871de0079d8d3133d648bda1e85182c88..bba96d2b6d3416cbbc582633085b32a4a1d9f193 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -254,7 +254,10 @@ AC_ARG_WITH(tcp-wrappers,
+ [Use TCP Wrappers @<:@default=auto@:>@]),,
+ with_tcp_wrappers=auto)
+
+-
++AC_ARG_WITH([udevdir],
++ AS_HELP_STRING([--with-udevdir=DIR],
++ [Directory for udev files]),
++ [with_udevdir=$withval], [with_udevdir=$($PKG_CONFIG --variable=udevdir udev)])
+ AC_ARG_WITH([systemdsystemunitdir],
+ AS_HELP_STRING([--with-systemdsystemunitdir=DIR],
+ [Directory for systemd service files]),
+@@ -867,6 +870,11 @@ AC_PATH_PROG(SYSTEMD_X_SERVER, systemd-multi-seat-x, [/lib/systemd/systemd-multi
+ AC_SUBST(SYSTEMD_X_SERVER)
+ AC_DEFINE_UNQUOTED(SYSTEMD_X_SERVER,"$SYSTEMD_X_SERVER",[Path to systemd X server wrapper])
+
++if test "x$with_udevdir" != xno; then
++ AC_SUBST(UDEV_DIR, [$with_udevdir])
++fi
++AM_CONDITIONAL(INSTALL_UDEV_RULES, test x$with_udevdir != xno)
++
+ if test "x$with_systemdsystemunitdir" != xno; then
+ AC_SUBST(SYSTEMD_SYSTEM_UNIT_DIR, [$with_systemdsystemunitdir])
+ fi
+@@ -1517,6 +1525,7 @@ echo \
+ XDMCP support: ${XDMCP_SUPPORT}
+ SELinux support: ${use_selinux}
+ systemd unit dir: ${with_systemdsystemunitdir}
++ udev dir: ${with_udevdir}
+ plymouth support: ${use_plymouth}
+ wayland support: ${enable_wayland_support}
+ Build with RBAC: ${msg_rbac_shutdown}
+diff --git a/data/Makefile.am b/data/Makefile.am
+index 7c6a2eb38a85759218278b6ab9c7725f26eef990..162074f1c571b9d76164ac485643a28f0712292f 100644
+--- a/data/Makefile.am
++++ b/data/Makefile.am
+@@ -154,8 +154,10 @@ if ENABLE_ARCH_PAM_CONFIG
+ pam_files = $(pam_arch_files)
+ endif
+
+-udevrulesdir = /lib/udev/rules.d
++if INSTALL_UDEV_RULES
++udevrulesdir = $(UDEV_DIR)/rules.d
+ udevrules_DATA = 61-gdm.rules
++endif
+
+ EXTRA_DIST += $(srcdir)/61-gdm.rules.in
+ 61-gdm.rules: $(srcdir)/61-gdm.rules.in
+
diff --git a/PKGBUILD b/PKGBUILD
index 0d99b32de140..ab7af47b0ea5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
_pkgbase=gdm
pkgbase=gdm-plymouth
pkgname=(gdm-plymouth libgdm-plymouth)
-pkgver=3.28.2
+pkgver=3.30.0
pkgrel=1
pkgdesc="Gnome Display Manager with Plymouth support."
arch=('x86_64')
@@ -17,9 +17,11 @@ makedepends=('intltool' 'yelp-tools' 'gobject-introspection')
checkdepends=('check')
source=("https://gitlab.gnome.org/GNOME/gdm/-/archive/${pkgver}/${_pkgbase}-${pkgver}.tar.gz"
"0002-Xsession-Don-t-start-ssh-agent-by-default.patch"
+ "0003-autogoo-make-udev-rules-dir-configurable.patch"
"gdm.sysusers")
-sha256sums=('58886a0e544e1b4ecf817ab8a9ab8f12770cfc2408417dbe42b4973a032f4616'
+sha256sums=('b2064b9dfb0d55a7a398478a94c9f342e0098340324cddad5beb1aa57a0aa795'
'63f99db7623f078e390bf755350e5793db8b2c4e06622caf42eddc63cd39ecca'
+ '86dd6513fece2daac1d3e89c740162e2046e36be7aae255fa30115cbb6eeda12'
'6d9c8e38c7de85b6ec75e488585b8c451f5d9b4fabd2a42921dc3bfcc4aa3e13')
prepare() {
@@ -27,6 +29,9 @@ prepare() {
patch -Np1 -i ../0002-Xsession-Don-t-start-ssh-agent-by-default.patch
+ # Remove for releases after 3.30
+ patch -Np1 -i ../0003-autogoo-make-udev-rules-dir-configurable.patch
+
NOCONFIGURE=1 ./autogen.sh
}