summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNanoArch2015-07-27 17:37:18 +0200
committerNanoArch2015-07-27 17:37:18 +0200
commit847df8b5dcc3ac5a32a4b207da619c7b2be76483 (patch)
tree0be40b2d614d2b4ce12ca2b35342e3a77213cd86
downloadaur-847df8b5dcc3ac5a32a4b207da619c7b2be76483.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD25
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ad1157229e01
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = gdm3setup-utils
+ pkgdesc = Utilities to configure GDM3, autologin options and change Shell theme
+ pkgver = 20150507
+ pkgrel = 1
+ url = http://github.com/Nano77/gdm3setup
+ arch = any
+ license = GPL
+ depends = gdm
+ depends = gnome-shell
+ depends = python2-dbus
+ conflicts = gdm3setup-daemon-native-theme
+ conflicts = gdm3setup-vala
+ conflicts = gdm3setup-vala-native-theme
+ source = https://raw.github.com/Nano77/various/master/src/gdm3setup-utils/gdm3setup-utils-20150507.tar.xz
+ sha256sums = 07d6e79ee4fd2ae27272106f7f9512ed6e404c782fa0c8582c6302236156fcf7
+
+pkgname = gdm3setup-utils
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..997ef18c56f2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: NanoArch <nanoarch77@gmail.com>
+
+pkgname=gdm3setup-utils
+pkgver=20150507
+pkgrel=1
+pkgdesc="Utilities to configure GDM3, autologin options and change Shell theme"
+arch=(any)
+license=('GPL')
+url="http://github.com/Nano77/gdm3setup"
+source=(https://raw.github.com/Nano77/various/master/src/$pkgname/$pkgname-$pkgver.tar.xz)
+
+
+depends=('gdm' 'gnome-shell' 'python2-dbus')
+conflicts=('gdm3setup-daemon-native-theme' 'gdm3setup-vala' 'gdm3setup-vala-native-theme')
+sha256sums=('07d6e79ee4fd2ae27272106f7f9512ed6e404c782fa0c8582c6302236156fcf7')
+
+build() {
+ cd ${srcdir}/$pkgname-$pkgver
+ make
+}
+
+package() {
+ cd ${srcdir}/$pkgname-$pkgver
+ make DESTDIR=${pkgdir} install
+}