summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2015-07-09 00:49:43 -0600
committerBrian Bidulock2015-07-09 00:49:43 -0600
commit919e3884aec0215f3b9c906b2fa12d1a3227e3c2 (patch)
tree9290b398e6d8257c4b7580c114ba786edcba8055
downloadaur-919e3884aec0215f3b9c906b2fa12d1a3227e3c2.tar.gz
initial version
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD34
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..052e0370bd97
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = gdmenu
+ pkgdesc = GTK+ dmenu clone
+ pkgver = r18.d0b9dfc
+ pkgrel = 1
+ url = https://github.com/rliang/gdmenu
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = gtk3
+ provides = gdmenu
+ conflicts = gdmenu
+ source = git+https://github.com/rliang/gdmenu.git
+ md5sums = SKIP
+
+pkgname = gdmenu
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e6d31455965d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Paul Pletenev <cpp.create@gmail.com>
+# Contributor: Ricardo Liang (rliang) <ricardoliang@gmail.com>
+
+pkgname=gdmenu
+pkgver=r18.d0b9dfc
+pkgrel=1
+pkgdesc="GTK+ dmenu clone"
+arch=('i686' 'x86_64')
+url="https://github.com/rliang/gdmenu"
+license=('MIT')
+depends=('gtk3')
+makedepends=('git')
+conflicts=('gdmenu')
+provides=('gdmenu')
+source=('git+https://github.com/rliang/gdmenu.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ # Use the tag of the last commit
+ #git describe --long --tags | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$pkgname"
+ unset LDFLAGS
+ make
+}
+
+package() {
+ cd "$pkgname"
+ make PREFIX=$pkgdir/usr/ install
+}