summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbluemeda2016-03-25 13:40:37 +0700
committerbluemeda2016-03-25 13:40:37 +0700
commit8ebfdc190ef6a0a19a770a5fb4865efb49fd1b40 (patch)
tree2634905bb0a2377dae90e39bb259c345992810aa
parentfe1f20c67241c5c7aada713fdd796b2932b94e86 (diff)
downloadaur-8ebfdc190ef6a0a19a770a5fb4865efb49fd1b40.tar.gz
fix
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD19
2 files changed, 6 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eab03e2e9d28..672cedc31abf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,9 +9,9 @@ pkgbase = gdrive-bin
provides = gdrive
conflicts = gdrive
conflicts = gdrive-git
- source_x86_64 = https://docs.google.com/uc?id=0B3X9GlR6EmbnWksyTEtCM0VfaFE&export=download
+ source_x86_64 = gdrive::https://docs.google.com/uc?id=0B3X9GlR6EmbnWksyTEtCM0VfaFE&export=download
sha1sums_x86_64 = c636778c4a2c76e47ac731c142f4219a19c30263
- source_i686 = https://docs.google.com/uc?id=0B3X9GlR6EmbnbndOUW50ZVllZ3M&export=download
+ source_i686 = gdrive::https://docs.google.com/uc?id=0B3X9GlR6EmbnbndOUW50ZVllZ3M&export=download
sha1sums_i686 = 0968993e4a70a594e0f315034640fd811977e4f1
pkgname = gdrive-bin
diff --git a/PKGBUILD b/PKGBUILD
index 5b0cef7ecd8d..64bb07d83c70 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,28 +9,17 @@ url="https://github.com/prasmussen/gdrive"
license=('MIT')
provides=('gdrive')
conflicts=('gdrive' 'gdrive-git')
-source_i686=("https://docs.google.com/uc?id=0B3X9GlR6EmbnbndOUW50ZVllZ3M&export=download")
-source_x86_64=("https://docs.google.com/uc?id=0B3X9GlR6EmbnWksyTEtCM0VfaFE&export=download")
+source_i686=("$_pkgname::https://docs.google.com/uc?id=0B3X9GlR6EmbnbndOUW50ZVllZ3M&export=download")
+source_x86_64=("$_pkgname::https://docs.google.com/uc?id=0B3X9GlR6EmbnWksyTEtCM0VfaFE&export=download")
sha1sums_i686=('0968993e4a70a594e0f315034640fd811977e4f1')
sha1sums_x86_64=('c636778c4a2c76e47ac731c142f4219a19c30263')
-package_x86_64() {
- cd "$srcdir/"
-
+package() {
install -dm755 "$pkgdir/usr/bin"
-
- install -Dm755 "$srcdir/uc?id=0B3X9GlR6EmbnWksyTEtCM0VfaFE&export=download" "$pkgdir/usr/bin/$_pkgname"
+ install -Dm755 "$srcdir/$_pkgname" "$pkgdir/usr/bin/$_pkgname"
}
-package_i686() {
- cd "$srcdir/"
-
- install -dm755 "$pkgdir/usr/bin"
-
- install -Dm755 "$srcdir/uc?id=0B3X9GlR6EmbnbndOUW50ZVllZ3M&export=download" "$pkgdir/usr/bin/$_pkgname"
-
-}
# vim:sw=4:ts=4:et