summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbluemeda2016-03-25 12:53:56 +0700
committerbluemeda2016-03-25 12:53:56 +0700
commitfe1f20c67241c5c7aada713fdd796b2932b94e86 (patch)
tree0b1e013caad45e9417f542a4deadc42a850155f9
downloadaur-fe1f20c67241c5c7aada713fdd796b2932b94e86.tar.gz
first build
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD36
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eab03e2e9d28
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = gdrive-bin
+ pkgdesc = Command line utility for uploading and downloading single files to your Google Drive
+ pkgver = 2.0.1
+ pkgrel = 1
+ url = https://github.com/prasmussen/gdrive
+ arch = x86_64
+ arch = i686
+ license = MIT
+ provides = gdrive
+ conflicts = gdrive
+ conflicts = gdrive-git
+ source_x86_64 = https://docs.google.com/uc?id=0B3X9GlR6EmbnWksyTEtCM0VfaFE&export=download
+ sha1sums_x86_64 = c636778c4a2c76e47ac731c142f4219a19c30263
+ source_i686 = https://docs.google.com/uc?id=0B3X9GlR6EmbnbndOUW50ZVllZ3M&export=download
+ sha1sums_i686 = 0968993e4a70a594e0f315034640fd811977e4f1
+
+pkgname = gdrive-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5b0cef7ecd8d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: bluemeda <affif[dot]bluemeda[at]gmail[dot]com>
+pkgname=gdrive-bin
+_pkgname=gdrive
+pkgver=2.0.1
+pkgrel=1
+pkgdesc="Command line utility for uploading and downloading single files to your Google Drive"
+arch=('x86_64' 'i686')
+url="https://github.com/prasmussen/gdrive"
+license=('MIT')
+provides=('gdrive')
+conflicts=('gdrive' 'gdrive-git')
+source_i686=("https://docs.google.com/uc?id=0B3X9GlR6EmbnbndOUW50ZVllZ3M&export=download")
+source_x86_64=("https://docs.google.com/uc?id=0B3X9GlR6EmbnWksyTEtCM0VfaFE&export=download")
+sha1sums_i686=('0968993e4a70a594e0f315034640fd811977e4f1')
+sha1sums_x86_64=('c636778c4a2c76e47ac731c142f4219a19c30263')
+
+
+package_x86_64() {
+ cd "$srcdir/"
+
+ install -dm755 "$pkgdir/usr/bin"
+
+ install -Dm755 "$srcdir/uc?id=0B3X9GlR6EmbnWksyTEtCM0VfaFE&export=download" "$pkgdir/usr/bin/$_pkgname"
+
+}
+
+package_i686() {
+ cd "$srcdir/"
+
+ install -dm755 "$pkgdir/usr/bin"
+
+ install -Dm755 "$srcdir/uc?id=0B3X9GlR6EmbnbndOUW50ZVllZ3M&export=download" "$pkgdir/usr/bin/$_pkgname"
+
+}
+
+# vim:sw=4:ts=4:et