summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122021-05-29 16:46:40 +0200
committerwillemw122021-05-29 16:51:08 +0200
commit392488e2517f4b0af6cfe0378bb158326dd48fd4 (patch)
treefd6099e912d031241f175726ee6fbb6802cd52d7
parent30543ae530303c2bbda96aa29963a73cfeebfb58 (diff)
downloadaur-392488e2517f4b0af6cfe0378bb158326dd48fd4.tar.gz
Update build options
Change url back to https://github.com/prasmussen/gdrive Change source git:// to git+https:// Update "arch" Remove _pkgname
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD28
2 files changed, 20 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0a1739876f26..22874be447c0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,9 @@
pkgbase = gdrive-git
pkgdesc = Google Drive CLI Client
- pkgver = 2.0.1.r3.g401e017
+ pkgver = 2.1.0.r35.gfb08fe2
pkgrel = 1
- url = https://github.com/gdrive-org/gdrive
+ url = https://github.com/prasmussen/gdrive
arch = x86_64
- arch = i686
license = MIT
makedepends = git
makedepends = go
@@ -12,7 +11,7 @@ pkgbase = gdrive-git
conflicts = gdrive
options = !strip
options = !emptydirs
- source = gdrive-git::git://github.com/prasmussen/gdrive.git
+ source = gdrive-git::git+https://github.com/prasmussen/gdrive.git
md5sums = SKIP
pkgname = gdrive-git
diff --git a/PKGBUILD b/PKGBUILD
index be038810356b..8371201e0605 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,20 @@
# Maintainer: willemw <willemw12@gmail.com>
-_pkgname=gdrive
-pkgname=$_pkgname-git
-pkgver=2.0.1.r3.g401e017
+pkgname=gdrive-git
+pkgver=2.1.0.r35.gfb08fe2
pkgrel=1
pkgdesc="Google Drive CLI Client"
-arch=('x86_64' 'i686')
-url="https://github.com/gdrive-org/gdrive"
+arch=('x86_64')
+url="https://github.com/prasmussen/gdrive"
license=('MIT')
makedepends=('git' 'go')
-provides=($_pkgname)
-conflicts=($_pkgname)
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
options=('!strip' '!emptydirs')
-source=($pkgname::git://github.com/prasmussen/gdrive.git)
+source=($pkgname::git+$url.git)
md5sums=('SKIP')
-_gourl=github.com/prasmussen/gdrive
+_gopkg=github.com/prasmussen/gdrive
pkgver() {
cd $pkgname
@@ -23,11 +22,18 @@ pkgver() {
}
build() {
- GOPATH="$srcdir/build" go get -fix -v -x $_gourl
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+ export GOPATH="$srcdir/build"
+ go get $_gopkg
}
#check() {
-# GOPATH="$srcdir/build" go test -fix -v -x $_gourl
+# export GOPATH="$srcdir/build"
+# go test $_gopkg
#}
package() {