summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122015-06-08 12:00:45 +0200
committerwillemw122015-06-08 12:00:45 +0200
commit7ad2b9606da76767ec350f4a8ed0041f3d74e02c (patch)
tree41789671cfaef58f14c418083a85167c79d0fc91
downloadaur-7ad2b9606da76767ec350f4a8ed0041f3d74e02c.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD43
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8265269383ef
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = gdrive-git
+ pkgdesc = Google Drive CLI Client
+ pkgver = 1.8.0.r1.g385b8b9
+ pkgrel = 1
+ url = https://github.com/prasmussen/gdrive
+ arch = x86_64
+ arch = i686
+ license = MIT
+ makedepends = git
+ makedepends = go
+ makedepends = mercurial
+ provides = gdrive
+ conflicts = gdrive
+ options = !strip
+ options = !emptydirs
+ source = gdrive-git::git://github.com/prasmussen/gdrive.git
+ md5sums = SKIP
+
+pkgname = gdrive-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..89f5969a6d4d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: willemw <willemw12@gmail.com>
+
+_pkgname=gdrive
+pkgname=$_pkgname-git
+pkgver=1.8.0.r1.g385b8b9
+pkgrel=1
+pkgdesc="Google Drive CLI Client"
+arch=('x86_64' 'i686')
+url="https://github.com/prasmussen/gdrive"
+license=('MIT')
+makedepends=('git' 'go' 'mercurial')
+provides=($_pkgname)
+conflicts=($_pkgname)
+options=('!strip' '!emptydirs')
+# 'source' is only used by pkgver() to set the package version
+source=($pkgname::git://github.com/prasmussen/gdrive.git)
+md5sums=('SKIP')
+
+_gourl=github.com/prasmussen/gdrive
+
+pkgver() {
+ cd $pkgname
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ GOPATH="$srcdir" go get -d -fix -v -x $_gourl
+}
+
+build() {
+ cd src/$_gourl
+ GOPATH="$srcdir" go build -v -x drive.go
+}
+
+#check() {
+# GOPATH="$GOPATH:$srcdir" go test -v -x $_gourl
+#}
+
+package() {
+ install -Dm755 src/$_gourl/drive "$pkgdir/usr/bin/gdrive"
+ install -Dm644 src/$_gourl/LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+