summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122023-04-29 09:31:18 +0200
committerwillemw122023-04-29 09:31:18 +0200
commitd6de7b2ad69e8a14a757f9485908db447eec5108 (patch)
tree4029340dddb0bcd7eb02e666c205e9bac1ef5750
parent0e1697dc02a51bf27848dc561e263954daada057 (diff)
downloadaur-d6de7b2ad69e8a14a757f9485908db447eec5108.tar.gz
Minor edits
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD23
2 files changed, 16 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2d68ef835f88..791b746459b5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gdrive-git
- pkgdesc = Google Drive CLI Client (Rust rewrite, git version)
+ pkgdesc = Google Drive CLI Client (Rust rewrite)
pkgver = 3.9.0.r2.g57e5ea6
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/glotlabs/gdrive
arch = x86_64
arch = aarch64
diff --git a/PKGBUILD b/PKGBUILD
index 16a063a2b4c5..f15cf33b7657 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,26 +3,25 @@
pkgname=gdrive-git
pkgver=3.9.0.r2.g57e5ea6
-pkgrel=1
-pkgdesc="Google Drive CLI Client (Rust rewrite, git version)"
+pkgrel=2
+pkgdesc="Google Drive CLI Client (Rust rewrite)"
arch=('x86_64' 'aarch64')
url="https://github.com/glotlabs/gdrive"
license=('MIT')
makedepends=('git' 'cargo')
-provides=('gdrive')
-conflicts=('gdrive')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
source=("$pkgname::git+$url.git")
sha256sums=('SKIP')
pkgver() {
git -C $pkgname describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
- cd $pkgname
}
prepare() {
cd $pkgname
export RUSTUP_TOOLCHAIN=stable
- cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+ cargo fetch --locked --target="$CARCH-unknown-linux-gnu"
}
build() {
@@ -32,9 +31,15 @@ build() {
cargo build --frozen --release --all-features
}
+#check() {
+# cd $pkgname
+# export RUSTUP_TOOLCHAIN=stable
+# export CARGO_TARGET_DIR=target
+# cargo test --frozen --all-features
+#}
+
package() {
cd $pkgname
- install -Dm0755 -t "$pkgdir/usr/bin/" "target/release/gdrive"
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm755 "target/release/${pkgname%-git}" -t "$pkgdir/usr/bin/"
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
}
-