summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122021-05-31 07:55:04 +0200
committerwillemw122021-05-31 07:55:04 +0200
commitedd24cca5c71b7d52ea533534c9a806cc7a298a4 (patch)
tree93cd1a9a8761fff54b3b2479dea094c178dcd8c9
parent392488e2517f4b0af6cfe0378bb158326dd48fd4 (diff)
downloadaur-edd24cca5c71b7d52ea533534c9a806cc7a298a4.tar.gz
Remove _gopkg
-rw-r--r--PKGBUILD9
1 files changed, 1 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8371201e0605..21b236f10a2a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,8 +14,6 @@ options=('!strip' '!emptydirs')
source=($pkgname::git+$url.git)
md5sums=('SKIP')
-_gopkg=github.com/prasmussen/gdrive
-
pkgver() {
cd $pkgname
git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
@@ -28,14 +26,9 @@ build() {
export CGO_LDFLAGS="${LDFLAGS}"
export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
export GOPATH="$srcdir/build"
- go get $_gopkg
+ go get "${url##*https://}"
}
-#check() {
-# export GOPATH="$srcdir/build"
-# go test $_gopkg
-#}
-
package() {
cd build
install -Dm755 bin/gdrive "$pkgdir/usr/bin/gdrive"