summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJavier Tiá2016-11-10 13:08:08 -0600
committerJavier Tiá2016-11-10 13:08:08 -0600
commit1fda54f949f29cee266cbf9a70f64c84768e1849 (patch)
tree4e25d33a8259b8e20dbb3bd2633fcec062572d28
parent3804a4d02937d434102337e261f2e7ab333c288b (diff)
downloadaur-1fda54f949f29cee266cbf9a70f64c84768e1849.tar.gz
Bump up gdrivefs 0.14.8-2
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD15
-rw-r--r--issue_166.patch32
3 files changed, 45 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b7d7b6ff175b..bb75d8741e90 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sun Jul 17 07:27:59 UTC 2016
+# Thu Nov 10 19:07:49 UTC 2016
pkgbase = gdrivefs
pkgdesc = A complete FUSE adapter for Google Drive
pkgver = 0.14.8
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/dsoprea/GDriveFS
arch = any
license = GPL2
diff --git a/PKGBUILD b/PKGBUILD
index e4cdfd9000eb..dec95efc5769 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,15 @@
# Maintainer: Javier Tiá <javier.tia at gmail dot com>
+# Contributors: Javier Vazquez <j.e.vasquez.v at gmail dot com>
+# Contributors: Nagy Gábor <ngm.hun at gmail dot com>
pkgname=gdrivefs
_gitname=GDriveFS
pkgver=0.14.8
-pkgrel=1
-pkgdesc="A complete FUSE adapter for Google Drive"
-url="https://github.com/dsoprea/GDriveFS"
-depends=('python2' 'python2-fusepy' 'python2-gevent' 'python2-google-api-python-client' 'python2-greenlet' 'python2-httplib2' 'python2-dateutil' 'python2-six' 'python2-wsgiref')
+pkgrel=2
+pkgdesc='A complete FUSE adapter for Google Drive'
+url='https://github.com/dsoprea/GDriveFS'
+depends=('python2' 'python2-fusepy' 'python2-gevent' 'python2-google-api-python-client'
+ 'python2-greenlet' 'python2-httplib2' 'python2-dateutil' 'python2-six' 'python2-wsgiref')
makedepends=('python2-distribute')
license=('GPL2')
arch=('any')
@@ -15,12 +18,16 @@ sha256sums=('7c7f0f8f3b7079f7823c0d27c751f3ae43c0ca0e7f6bbdf93da6dc29150890b5')
build() {
cd ${srcdir}/${_gitname}-${pkgver}
+
# Fix for multi threaded (issue 132)
patch -p1 < ../../pull_147.patch
# Add support to utf8 instead of ASCII
patch -p1 < ../../pull_154_utf8.patch
+ # Fix for oauth2client.util library
+ patch -p1 < ../../issue_166.patch
+
python2 setup.py build
}
diff --git a/issue_166.patch b/issue_166.patch
new file mode 100644
index 000000000000..a85c8b80edc8
--- /dev/null
+++ b/issue_166.patch
@@ -0,0 +1,32 @@
+--- GDriveFS-0.14.8_orig/gdrivefs/gdtool/chunked_download.py 2016-07-16 17:27:28.000000000 +0200
++++ GDriveFS-0.14.8/gdrivefs/gdtool/chunked_download.py 2016-11-10 15:58:06.000000000 +0100
+@@ -2,7 +2,10 @@
+ import time
+ import random
+
+-import oauth2client
++try:
++ from oauth2client import util
++except ImportError:
++ from oauth2client import _helpers as util
+ import apiclient.http
+ import apiclient.errors
+
+@@ -19,7 +22,7 @@
+ that needs to be downloaded (not a request object, which doesn't apply here).
+ """
+
+- @oauth2client.util.positional(4)
++ @util.positional(4)
+ def __init__(self, fd, http, uri, chunksize=DEFAULT_CHUNK_SIZE, start_at=0):
+ """Constructor.
+
+@@ -43,7 +46,7 @@
+ self._sleep = time.sleep
+ self._rand = random.random
+
+- @oauth2client.util.positional(1)
++ @util.positional(1)
+ def next_chunk(self, num_retries=0):
+ """Get the next chunk of the download.
+