summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJavier Tiá2016-03-21 19:30:44 -0600
committerJavier Tiá2016-03-21 19:30:44 -0600
commit7d38223c5e8c623dad4590274ab61da42a3f704a (patch)
tree4434700a72f2c0b36f6f755a44cde757d500b488
parentda1baebfff9f482ad24b82fdfcdad9a86f67f88d (diff)
downloadaur-7d38223c5e8c623dad4590274ab61da42a3f704a.tar.gz
Bump up gdrivefs 0.14.3-7
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
-rw-r--r--pull_134.patch20
-rw-r--r--pull_147.patch68
-rw-r--r--pull_154_utf8.patch24
5 files changed, 124 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index edc94e0e6758..2a0389c1a9fd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Tue Mar 22 01:29:25 UTC 2016
pkgbase = gdrivefs
- pkgdesc = A complete FUSE adapter for Google Drive.
+ pkgdesc = A complete FUSE adapter for Google Drive
pkgver = 0.14.3
- pkgrel = 5
+ pkgrel = 7
url = https://github.com/dsoprea/GDriveFS
arch = any
license = GPL2
diff --git a/PKGBUILD b/PKGBUILD
index 66fa74f2d364..18cb6476b7a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,23 @@
-# Maintainer: Javier Tia <javier.tia at gmail dot com>
+# Maintainer: Javier Tiá <javier.tia at gmail dot com>
+
pkgname=gdrivefs
_gitname=GDriveFS
pkgver=0.14.3
-pkgrel=5
-pkgdesc="A complete FUSE adapter for Google Drive."
+pkgrel=7
+pkgdesc="A complete FUSE adapter for Google Drive"
url="https://github.com/dsoprea/GDriveFS"
depends=('python2' 'python2-fusepy' 'python2-gevent' 'python2-google-api-python-client' 'python2-greenlet' 'python2-httplib2' 'python2-dateutil' 'python2-six' 'python2-wsgiref')
makedepends=('python2-distribute')
license=('GPL2')
arch=('any')
-source=("https://github.com/dsoprea/${_gitname}/archive/${pkgver}.tar.gz")
+source=("${url}/archive/${pkgver}.tar.gz")
sha256sums=('bbd8a566aab6181df606c4c86f75552f9d59dbe41040fe0ee0d4a9c515ae9f05')
build() {
cd ${srcdir}/${_gitname}-${pkgver}
+ patch -p1 < ../../pull_134.patch
+ patch -p1 < ../../pull_147.patch
+ patch -p1 < ../../pull_154_utf8.patch
python2 setup.py build
}
diff --git a/pull_134.patch b/pull_134.patch
new file mode 100644
index 000000000000..60c672e9b4d1
--- /dev/null
+++ b/pull_134.patch
@@ -0,0 +1,20 @@
+diff -Naur GDriveFS-0.14.3/gdrivefs/gdfs/gdfuse.py GDriveFS-0.14.3-new/gdrivefs/gdfs/gdfuse.py
+--- GDriveFS-0.14.3/gdrivefs/gdfs/gdfuse.py 2015-10-18 16:09:54.708226894 -0600
++++ GDriveFS-0.14.3-new/gdrivefs/gdfs/gdfuse.py 2015-10-18 16:15:17.431235540 -0600
+@@ -7,6 +7,7 @@
+ import atexit
+ import resource
+ import pprint
++import math
+
+ from errno import ENOENT, EIO, ENOTDIR, ENOTEMPTY, EPERM, EEXIST
+ from fuse import FUSE, Operations, FuseOSError, c_statvfs, fuse_get_context, \
+@@ -161,6 +162,8 @@
+ stat_result["st_mode"] = (stat.S_IFREG | effective_permission)
+ stat_result["st_nlink"] = 1
+
++ stat_result["st_blocks"] = int(math.ceil(float(stat_result["st_size"]) / 512.0))
++
+ return stat_result
+
+ @dec_hint(['raw_path', 'fh'])
diff --git a/pull_147.patch b/pull_147.patch
new file mode 100644
index 000000000000..f5f4c4664add
--- /dev/null
+++ b/pull_147.patch
@@ -0,0 +1,68 @@
+diff --git a/gdrivefs/config/__init__.py b/gdrivefs/config/__init__.py
+index f8c4749..3646db3 100644
+--- a/gdrivefs/config/__init__.py
++++ b/gdrivefs/config/__init__.py
+@@ -1,4 +1,5 @@
+ import os
+
+ IS_DEBUG = bool(int(os.environ.get('GD_DEBUG', '0')))
++NO_THREADS = bool(int(os.environ.get('GD_NOTHREADS', '1')))
+ DO_LOG_FUSE_MESSAGES = bool(int(os.environ.get('GD_DO_LOG_FUSE_MESSAGES', '0')))
+diff --git a/gdrivefs/resources/README.rst b/gdrivefs/resources/README.rst
+index 6e25a7c..f7400d2 100644
+--- a/gdrivefs/resources/README.rst
++++ b/gdrivefs/resources/README.rst
+@@ -225,6 +225,20 @@ Just set the `GD_DEBUG` environment variable to "1"::
+ flags=0x00000011
+
+
++Multi-threading FUSE
++====================
++
++It used to be that GDFS mounting used FUSE with no threads, only when running in
++debugging-mode, and actually if not in debugging-mode, FUSE was always used
++with threads.
++
++Currently, using FUSE with threads corrupts data reads, once mounted. Then now
++multi-threading is decoupled from debugging-mode, and by default set to no threads.
++
++To enable threads back when mounting GDFS, just set the `GD_NOTHREADS` environment
++variable to "0" (1 by default).
++
++
+ Troubleshooting Steps
+ =====================
+
+diff --git a/gdrivefs/resources/scripts/gdfs b/gdrivefs/resources/scripts/gdfs
+index b001787..a8673ff 100755
+--- a/gdrivefs/resources/scripts/gdfs
++++ b/gdrivefs/resources/scripts/gdfs
+@@ -40,7 +40,7 @@ def main():
+ auth_storage_filepath=args.auth_storage_file,
+ mountpoint=args.mountpoint,
+ debug=gdrivefs.config.IS_DEBUG,
+- nothreads=gdrivefs.config.IS_DEBUG,
++ nothreads=gdrivefs.config.NO_THREADS,
+ option_string=option_string)
+
+ if __name__ == '__main__':
+diff --git a/gdrivefs/resources/scripts/gdfstool b/gdrivefs/resources/scripts/gdfstool
+index da2820e..52aaf66 100755
+--- a/gdrivefs/resources/scripts/gdfstool
++++ b/gdrivefs/resources/scripts/gdfstool
+@@ -68,7 +68,7 @@ def _handle_mountpoint(args):
+ auth_storage_filepath=args.auth_storage_file,
+ mountpoint=args.mountpoint,
+ debug=gdrivefs.config.IS_DEBUG,
+- nothreads=gdrivefs.config.IS_DEBUG,
++ nothreads=gdrivefs.config.NO_THREADS,
+ option_string=option_string)
+
+ def main():
+@@ -122,4 +122,4 @@ def main():
+ raise Exception("Invalid option.")
+
+ if __name__ == '__main__':
+- main()
+\ No newline at end of file
++ main()
diff --git a/pull_154_utf8.patch b/pull_154_utf8.patch
new file mode 100644
index 000000000000..1c6e290c035c
--- /dev/null
+++ b/pull_154_utf8.patch
@@ -0,0 +1,24 @@
+diff -Naur GDriveFS-0.14.3-orig/gdrivefs/gdfs/opened_file.py GDriveFS-0.14.3/gdrivefs/gdfs/opened_file.py
+--- GDriveFS-0.14.3-orig/gdrivefs/gdfs/opened_file.py 2016-03-20 20:40:04.593869779 -0600
++++ GDriveFS-0.14.3/gdrivefs/gdfs/opened_file.py 2016-03-20 20:40:55.907851581 -0600
+@@ -197,7 +197,7 @@
+ self.__is_loaded = False
+ self.__is_dirty = False
+
+- temp_filename = self.__entry_id.encode('ASCII')
++ temp_filename = self.__entry_id.encode('utf8')
+ om = get_om()
+ self.__temp_filepath = os.path.join(om.temp_path, temp_filename)
+
+diff -Naur GDriveFS-0.14.3-orig/gdrivefs/gdtool/normal_entry.py GDriveFS-0.14.3/gdrivefs/gdtool/normal_entry.py
+--- GDriveFS-0.14.3-orig/gdrivefs/gdtool/normal_entry.py 2016-03-20 20:40:04.593869779 -0600
++++ GDriveFS-0.14.3/gdrivefs/gdtool/normal_entry.py 2016-03-20 20:41:27.672855022 -0600
+@@ -213,7 +213,7 @@
+ return data
+
+ def get_data(self):
+- original = dict([(key.encode('ASCII'), value)
++ original = dict([(key.encode('utf8'), value)
+ for key, value
+ in self.__raw_data.iteritems()])
+