summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Wadley2020-05-14 22:57:03 -0400
committerTom Wadley2020-05-14 22:57:03 -0400
commit43e163b245ce344367aeacdcf894692ee9367183 (patch)
tree2438f0a38704d1de23cb4c4d2e1e9c1117d16a42
downloadaur-43e163b245ce344367aeacdcf894692ee9367183.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD38
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9cdd93b41880
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = gdx-skin-composer
+ pkgdesc = Create skins for LibGDX scene2d.ui with a graphical interface
+ pkgver = 34
+ pkgrel = 1
+ url = https://github.com/raeleus/skin-composer
+ arch = any
+ license = MIT
+ depends = java-runtime
+ source = gdx-skin-composer-34.zip::https://github.com/raeleus/skin-composer/releases/download/34/skin-composer-linux.zip
+ source = gdx-skin-composer-34-LICENSE::https://raw.githubusercontent.com/raeleus/skin-composer/34/LICENSE
+ sha256sums = 94bec1d8513aa6eb180612201704a66651867bd86c53e9a0bedd8d9071a151e6
+ sha256sums = 65692928853a587a07bafe89d2449e1cf0f28dcc3fd2b0c4116a646ef63d7bcd
+
+pkgname = gdx-skin-composer
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..14fcdc432313
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src/
+*.zip
+*.pkg.*
+*-LICENSE
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ea5ebd835e7e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Tom Wadley <tom@tomwadley.net>
+pkgname=gdx-skin-composer
+pkgver=34
+pkgrel=1
+pkgdesc="Create skins for LibGDX scene2d.ui with a graphical interface"
+arch=('any')
+url="https://github.com/raeleus/skin-composer"
+license=('MIT')
+depends=('java-runtime')
+source=("$pkgname-$pkgver.zip::https://github.com/raeleus/skin-composer/releases/download/$pkgver/skin-composer-linux.zip"
+ "$pkgname-$pkgver-LICENSE::https://raw.githubusercontent.com/raeleus/skin-composer/$pkgver/LICENSE")
+sha256sums=('94bec1d8513aa6eb180612201704a66651867bd86c53e9a0bedd8d9071a151e6'
+ '65692928853a587a07bafe89d2449e1cf0f28dcc3fd2b0c4116a646ef63d7bcd')
+
+prepare() {
+ cat <<EOF > $pkgname
+#!/bin/sh
+exec /usr/bin/java -jar '/usr/share/java/$pkgname/$pkgname.jar' "\$@"
+EOF
+
+ cat <<EOF > $pkgname.desktop
+[Desktop Entry]
+Type=Application
+Name=Skin Composer
+Comment=$pkgdesc
+Exec=/usr/bin/$pkgname
+Icon=$pkgname
+Categories=Development;
+EOF
+}
+
+package() {
+ install -Dm 755 $pkgname "$pkgdir/usr/bin/$pkgname"
+ install -Dm 644 $pkgname-$pkgver-LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm 644 $pkgname.desktop "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -Dm 644 app/SkinComposer.jar "$pkgdir/usr/share/java/$pkgname/$pkgname.jar"
+ install -Dm 644 bin/SkinComposer.png "$pkgdir/usr/share/pixmaps/$pkgname.png"
+}