summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorL.G. Sarmiento2017-12-10 22:28:21 +0100
committerL.G. Sarmiento2017-12-10 22:28:21 +0100
commit31e213690609cc61548079831ab52ae8fc1c3f5b (patch)
treebe0e91c3474e09bf41544f872c27df0a4f2fe7c5
parent5a82d44da4051cb5358d7e7b952e85f60bb0eea9 (diff)
downloadaur-31e213690609cc61548079831ab52ae8fc1c3f5b.tar.gz
updated to 10.4
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD32
2 files changed, 16 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d6495d838816..84426a8632b2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Mon Oct 23 07:54:04 UTC 2017
+# Sun Dec 10 21:27:18 UTC 2017
pkgbase = geant4
pkgdesc = A simulation toolkit for particle physics interactions.
- pkgver = 10.3.3
+ pkgver = 10.4.0
pkgrel = 1
url = http://geant4.cern.ch/
install = geant4.install
@@ -11,20 +11,7 @@ pkgbase = geant4
license = custom: http://geant4.cern.ch/license/
depends = cmake>=2.8.2
depends = xerces-c
- depends = qt5-connectivity
- depends = qt5-graphicaleffects
- depends = qt5-imageformats
- depends = qt5-multimedia
- depends = qt5-quick1
- depends = qt5-quickcontrols
- depends = qt5-serialport
- depends = qt5-svg
- depends = qt5-tools
- depends = qt5-translations
- depends = qt5-wayland
- depends = qt5-webengine
- depends = qt5-websockets
- depends = qt5-x11extras
+ depends = qt5-base
depends = glu
depends = soxt
optdepends = java-environment: for histogram visualizations and analysis
@@ -40,11 +27,11 @@ pkgbase = geant4
optdepends = geant4-radioactivedata: Data files for radioactive decay hadronic processes
optdepends = geant4-realsurfacedata: Data files for measured optical surface reflectance
optdepends = geant4-saiddata: Data files from evaluated cross-sections in SAID data-base
- replaces = geant4-deb
+ conflicts = geant4_devel
options = !emptydirs
- source = http://geant4.cern.ch/support/source/geant4.10.03.p03.tar.gz
+ source = http://geant4.cern.ch/support/source/geant4.10.04.tar.gz
source = geant4.install
- md5sums = ccae9fd18e3908be78784dc207f2d73b
+ md5sums = b84beeb756821d0c61f7c6c93a2b83de
md5sums = bfe6791027de966cad240d8584c6b657
pkgname = geant4
diff --git a/PKGBUILD b/PKGBUILD
index 21df77cfa34e..76e3eada1685 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,16 @@
# Maintainer: Luis Sarmiento < Luis.Sarmiento-ala-nuclear.lu.se >
pkgname='geant4'
-pkgver=10.3.3
-_pkgver=10.03.p03
+pkgver=10.4.0
+_pkgver=10.04
pkgrel=1
pkgdesc="A simulation toolkit for particle physics interactions."
depends=('cmake>=2.8.2'
'xerces-c'
- 'qt5-connectivity'
- 'qt5-graphicaleffects'
- 'qt5-imageformats'
- 'qt5-multimedia'
- 'qt5-quick1'
- 'qt5-quickcontrols'
- 'qt5-serialport'
- 'qt5-svg'
- 'qt5-tools'
- 'qt5-translations'
- 'qt5-wayland'
- 'qt5-webengine'
- 'qt5-websockets'
- 'qt5-x11extras'
+ 'qt5-base'
'glu'
'soxt'
)
-replaces=('geant4-deb')
+conflicts=('geant4_devel')
optdepends=('java-environment: for histogram visualizations and
analysis'
'tcsh: for C Shell support'
@@ -45,7 +32,7 @@ options=('!emptydirs')
install="${pkgname}.install"
source=("http://geant4.cern.ch/support/source/${pkgname}.${_pkgver}.tar.gz"
"${pkgname}.install")
-md5sums=('ccae9fd18e3908be78784dc207f2d73b'
+md5sums=('b84beeb756821d0c61f7c6c93a2b83de'
'bfe6791027de966cad240d8584c6b657')
## Remove this if you want to keep an even smaller package
@@ -53,15 +40,16 @@ md5sums=('ccae9fd18e3908be78784dc207f2d73b'
PKGEXT='.pkg.tar'
build() {
+
[ -d ${srcdir}/build ] || mkdir ${srcdir}/build
cd ${srcdir}/build
+
env -i \
- CXXFLAGS="${CXXFLAGS} -std=c++14" \
QT_SELECT=5 \
PATH=/usr/bin \
cmake \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_BUILD_TYPE=RELEASE \
-DGEANT4_BUILD_MULTITHREADED=ON \
-DGEANT4_BUILD_CXXSTD=14 \
-DGEANT4_INSTALL_DATA=OFF \
@@ -79,7 +67,7 @@ build() {
-DCMAKE_INSTALL_LIBDIR=lib \
../${pkgname}.${_pkgver}
- make
+ G4VERBOSE=1 make
}
@@ -90,7 +78,7 @@ package() {
#files are also available on the AUR and the environment variables
#are set automatically for you from the packages.
- msg "Removing wrongly set environment variables"
+ msg "Removing 'wrongly' set environment variables"
variables=("G4NEUTRONHPDATA" \
"G4LEDATA" \