summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorL.G. Sarmiento2015-06-14 19:39:30 +0200
committerL.G. Sarmiento2015-06-14 19:39:30 +0200
commit62f96fbee9d95c5b9c47c371d29aa0937175d433 (patch)
tree2fe24ef8d96cb0b3d11399e549a835209edcdd23
downloadaur-62f96fbee9d95c5b9c47c371d29aa0937175d433.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
-rw-r--r--geant4-radioactivedata.install35
3 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..09d0482e9000
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = geant4-radioactivedata
+ pkgdesc = Data files for radioactive decay hadronic processes
+ pkgver = 4.2
+ pkgrel = 1
+ url = http://geant4.cern.ch/
+ install = geant4-radioactivedata.install
+ arch = any
+ license = GPL
+ depends = geant4>=10.01
+ source = http://geant4.cern.ch/support/source/G4RadioactiveDecay.4.2.tar.gz
+ source = geant4-radioactivedata.install
+ md5sums = 2eade8116387ef67d4cd6f14b9cb1512
+ md5sums = d0144370a60b4de8d8b29c0920f6b00b
+
+pkgname = geant4-radioactivedata
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dbf3f6423d83
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: L.G. Sarmiento (Pico) <Luis.Sarmientop-ala-nuclear.lu.se>
+pkgname=geant4-radioactivedata
+_dataname="G4RadioactiveDecay"
+_foldername="RadioactiveDecay"
+pkgver=4.2
+pkgrel=1
+pkgdesc="Data files for radioactive decay hadronic processes"
+url="http://geant4.cern.ch/"
+arch=('any')
+license=('GPL')
+depends=('geant4>=10.01')
+#it cannot be optdepend since we require the geant4.sh file to exist
+#to setup the environment variable
+install="${pkgname}.install"
+source=("http://geant4.cern.ch/support/source/${_dataname}.${pkgver}.tar.gz"
+ "${pkgname}.install")
+md5sums=('2eade8116387ef67d4cd6f14b9cb1512'
+ 'd0144370a60b4de8d8b29c0920f6b00b')
+
+## Remove this if you want to keep an even smaller package
+## No need to wait for compression when just installing it.
+PKGEXT='.pkg.tar'
+
+package() {
+ install -d ${pkgdir}/usr/share/${pkgname}
+ mv ${srcdir}/${_foldername}${pkgver} ${pkgdir}/usr/share/${pkgname}
+}
diff --git a/geant4-radioactivedata.install b/geant4-radioactivedata.install
new file mode 100644
index 000000000000..a1bf56bdd8d8
--- /dev/null
+++ b/geant4-radioactivedata.install
@@ -0,0 +1,35 @@
+#!/bin/sh
+
+_varname='G4RADIOACTIVEDATA'
+_packagename='geant4-radioactivedata'
+_foldername='RadioactiveDecay'
+_dataversion=4.2
+
+_add() {
+ echo "export ${_varname}=/usr/share/${_packagename}/${_foldername}${_dataversion}" >> /etc/profile.d/geant4.sh
+ echo "setenv ${_varname} /usr/share/${_packagename}/${_foldername}${_dataversion}" >> /etc/profile.d/geant4.csh
+}
+
+_remove() {
+ sed -i "/${_varname}/d" /etc/profile.d/geant4.sh
+ sed -i "/${_varname}/d" /etc/profile.d/geant4.csh
+}
+
+pre_install() {
+ _remove
+}
+post_install() {
+ _add
+}
+pre_upgrade() {
+ _remove
+}
+post_upgrade() {
+ _add
+}
+pre_remove() {
+ _remove
+}
+post_remove() {
+ _remove
+}