summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYamashita Ren2015-08-29 01:37:10 +0200
committerYamashita Ren2015-08-29 01:37:10 +0200
commit6c4bad9433dc0354715ca30f1e57a07a8084888b (patch)
tree9267c4b8c51fed7461eb124ac34fdac19e3f76cc
downloadaur-6c4bad9433dc0354715ca30f1e57a07a8084888b.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD21
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6eb69d54f2e4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = geany-highlightselectedword
+ pkgdesc = It is a Geany plugin that high lights (highlights) the word that is currently selected in the editor. It works with geany-1.23.1. It also works with geany-1.24.1.
+ pkgver = r5
+ pkgrel = 1
+ url = http://geanyhighlightselectedword.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = geany
+ source = https://sourceforge.net/projects/geanyhighlightselectedword/files/GeanyHighlightSelectedWord.zip
+ md5sums = SKIP
+
+pkgname = geany-highlightselectedword
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..002b9ba76aaa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+#Maintainer: YamashitaRen <lemaitre(dot)lotus(at)gmail(dot)com>
+pkgname=geany-highlightselectedword
+pkgver=r5
+pkgrel=1
+pkgdesc='It is a Geany plugin that high lights (highlights) the word that is currently selected in the editor. It works with geany-1.23.1. It also works with geany-1.24.1.'
+url='http://geanyhighlightselectedword.sourceforge.net/'
+license=('GPL')
+arch=('i686' 'x86_64')
+depends=('geany')
+source=('https://sourceforge.net/projects/geanyhighlightselectedword/files/GeanyHighlightSelectedWord.zip')
+md5sums=('SKIP')
+
+build() {
+ cd $srcdir/GeanyHighlightSelectedWord/oneTwoFive
+ make
+}
+
+package() {
+ cd $srcdir/GeanyHighlightSelectedWord/oneTwoFive
+ install -D GeanyHighlightSelectedWord.so "$pkgdir/usr/lib/geany/GeanyHighlightSelectedWord.so"
+}