summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJordan Christiansen2016-04-20 14:32:41 -0500
committerJordan Christiansen2016-04-20 14:32:41 -0500
commit3765a6741e649ac2337b6a2a7f0e1ce80dd5f405 (patch)
tree6461bc8b86ba5bba5b730ce3767d457fe0a1c5f4
parentc20d148bdce68f798cc06fe4d2058f2268ed88be (diff)
downloadaur-3765a6741e649ac2337b6a2a7f0e1ce80dd5f405.tar.gz
Updated to version 1.301
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0878f3711522..70ac99b345ef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gearhead
pkgdesc = A rougelike mecha role playing game
- pkgver = 1.300
- pkgrel = 2
+ pkgver = 1.301
+ pkgrel = 1
url = http://www.gearheadrpg.com/
arch = i686
arch = x86_64
@@ -10,11 +10,11 @@ pkgbase = gearhead
depends = sdl
depends = sdl_image
depends = sdl_ttf
- source = https://github.com/jwvhewitt/gearhead-1/archive/v1.300.tar.gz
+ source = https://github.com/jwvhewitt/gearhead-1/archive/v1.301.tar.gz
source = gearhead.sh
source = gearhead.desktop
source = gearhead.png
- md5sums = 82be0ad5093eeecbe6feea1b8fa2acd5
+ md5sums = c65732798458861786908c1bbd424ee7
md5sums = cd699f36df6275bdb6b345cb5ac8f8f1
md5sums = a97a4a561783e23767e223476c0e7899
md5sums = 19f59e008bbe3fdcf39363818d3a5cf1
diff --git a/PKGBUILD b/PKGBUILD
index 8500cb350765..27cf38579bc3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,32 +5,33 @@
# package contents to /usr/bin/ and /usr/share/.
pkgname=gearhead
-pkgver=1.300
-pkgrel=2
+_reponame=gearhead-1
+pkgver=1.301
+pkgrel=1
pkgdesc="A rougelike mecha role playing game"
arch=(i686 x86_64)
url="http://www.gearheadrpg.com/"
license=('LGPL')
depends=(sdl sdl_image sdl_ttf)
makedepends=(fpc)
-source=("https://github.com/jwvhewitt/${pkgname}-1/archive/v${pkgver}.tar.gz"
+source=("https://github.com/jwvhewitt/${_reponame}/archive/v${pkgver}.tar.gz"
${pkgname}.sh
${pkgname}.desktop
${pkgname}.png)
-md5sums=('82be0ad5093eeecbe6feea1b8fa2acd5'
+md5sums=('c65732798458861786908c1bbd424ee7'
'cd699f36df6275bdb6b345cb5ac8f8f1'
'a97a4a561783e23767e223476c0e7899'
'19f59e008bbe3fdcf39363818d3a5cf1')
build() {
- cd "${pkgname}-1-${pkgver}"
+ cd "${_reponame}-${pkgver}"
fpc -dSDLMODE gharena
}
package() {
# Install the game itself.
- cd "${pkgname}-1-${pkgver}"
+ cd "${_reponame}-${pkgver}"
install -d "${pkgdir}/opt/${pkgname}"
cp -ar -t "${pkgdir}/opt/${pkgname}" Image Design GameData Series doc
install -Dm755 gharena "${pkgdir}/opt/${pkgname}"