summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTorben2020-01-31 22:36:12 +0100
committerTorben2020-01-31 22:40:44 +0100
commit58839ed4c839fa9ddd166693a97981f80df9d6bd (patch)
treebce3cdea4a5d64b3f396d478745c7b1416c75267
parentfd3a3318ddfba2704acf1f5f9026a46f92f42fcf (diff)
downloadaur-58839ed4c839fa9ddd166693a97981f80df9d6bd.tar.gz
Remove libhandy patch; Update .SRCINFO
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--force-system-libhandy.patch40
3 files changed, 4 insertions, 49 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8a7b1ae7ea1..7ed4e70712b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = geary-git
pkgdesc = An email application built around conversations, for the GNOME 3 desktop.
- pkgver = r5394.b08cee78
+ pkgver = r5442.c4d0b714
pkgrel = 1
url = https://gitlab.gnome.org/GNOME/geary
arch = i686
@@ -32,9 +32,7 @@ pkgbase = geary-git
provides = geary
conflicts = geary
source = git+https://gitlab.gnome.org/GNOME/geary.git
- source = force-system-libhandy.patch
sha256sums = SKIP
- sha256sums = e55e842557f68c3630a2ad1fa19b09bbaf0d1bdeb556650dd9065794cdc80de9
pkgname = geary-git
diff --git a/PKGBUILD b/PKGBUILD
index e1e6f85af91..675e8c15238 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Massimiliano Torromeo <massimiliano.torromeo at gmail dot com>
pkgname=geary-git
-pkgver=r5394.b08cee78
+pkgver=r5442.c4d0b714
pkgrel=1
pkgdesc="An email application built around conversations, for the GNOME 3 desktop."
arch=(i686 x86_64)
@@ -17,10 +17,8 @@ depends=('appstream-glib' 'enchant' 'folks' 'gcr' 'gmime3' 'gtk3'
makedepends=('git' 'gobject-introspection' 'itstool' 'meson' 'vala')
provides=('geary')
conflicts=('geary')
-source=('git+https://gitlab.gnome.org/GNOME/geary.git'
- 'force-system-libhandy.patch')
-sha256sums=('SKIP'
- 'e55e842557f68c3630a2ad1fa19b09bbaf0d1bdeb556650dd9065794cdc80de9')
+source=('git+https://gitlab.gnome.org/GNOME/geary.git')
+sha256sums=('SKIP')
pkgver() {
cd "$srcdir/geary"
@@ -30,7 +28,6 @@ pkgver() {
prepare() {
cd "$srcdir/geary"
rm -rf build
- patch -Np1 -i ../force-system-libhandy.patch
}
build() {
diff --git a/force-system-libhandy.patch b/force-system-libhandy.patch
deleted file mode 100644
index 74e977ba5d1..00000000000
--- a/force-system-libhandy.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-diff --git a/meson.build b/meson.build
-index 98d4527f..d4015e7e 100644
---- a/meson.build
-+++ b/meson.build
-@@ -88,7 +88,7 @@ gthread = dependency('gthread-2.0', version: '>=' + target_glib)
- iso_codes = dependency('iso-codes')
- javascriptcoregtk = dependency('javascriptcoregtk-4.0', version: '>=' + target_webkit)
- json_glib = dependency('json-glib-1.0', version: '>= 1.0')
--libhandy = dependency('libhandy-0.0', version: '>= 0.0.9', required: false)
-+libhandy = dependency('libhandy-0.0', version: '>= 0.0.9')
- libmath = cc.find_library('m')
- libpeas = dependency('libpeas-1.0', version: '>= 1.24.0')
- libsecret = dependency('libsecret-1', version: '>= 0.11')
-@@ -109,26 +109,6 @@ if not enchant.found()
- enchant = dependency('enchant', version: '>=1.6')
- endif
-
--# Handy isn't necessarily packaged by distros, so fall back to a
--# subproject until it is.
--if not libhandy.found()
-- libhandy_subproj = subproject(
-- 'libhandy',
-- default_options: [
-- 'examples=false',
-- 'glade_catalog=disabled',
-- 'tests=false',
-- ]
-- )
--
-- libhandy = declare_dependency(
-- dependencies: [
-- libhandy_subproj.get_variable('libhandy_dep'),
-- libhandy_subproj.get_variable('libhandy_vapi'),
-- ]
-- )
--endif
--
- # Libunwind system dependencies above ensures appropriate versions,
- # but this declared depencency is what we actually build against so we
- # can include the custom VAPI correctly. We need to add unwind_lib to