summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Husmann2015-06-09 00:22:19 +0200
committerStefan Husmann2015-06-09 00:22:19 +0200
commit399f48daf377f5d692dbba9209017d0200701b8a (patch)
treea70497940a6ef035363b38ca668adc76c5c70b68
downloadaur-399f48daf377f5d692dbba9209017d0200701b8a.tar.gz
initial version
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD44
-rw-r--r--geda-gaf.install19
3 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..64fe8f41f1d4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = geda-gaf-unstable
+ pkgdesc = gEDA/gaf suite - contains gschem, gnetlist, gsymcheck, gattrib, utilities and documentation from the gEDA project
+ pkgver = 1.9.1
+ pkgrel = 1
+ url = http://www.geda-project.org/
+ install = geda-gaf.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = gtk2
+ depends = guile
+ depends = libstroke
+ depends = hicolor-icon-theme
+ depends = desktop-file-utils
+ optdepends = python2: for two of the commands (garchive, tragesym)
+ optdepends = gawk: for sw2asc
+ provides = geda-gaf
+ conflicts = geda-gaf
+ source = http://ftp.geda-project.org/geda-gaf/unstable/v1.9/1.9.1/geda-gaf-1.9.1.tar.gz
+ md5sums = bf8949956e18f34513e503fa1f11f3d5
+
+pkgname = geda-gaf-unstable
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d5b27eebf00f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Contributor: Jared Casper <jaredcasper@gmail.com>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=geda-gaf-unstable
+_pkgname=geda-gaf
+pkgver=1.9.1
+pkgrel=1
+pkgdesc="gEDA/gaf suite - contains gschem, gnetlist, gsymcheck, gattrib, utilities and documentation from the gEDA project"
+arch=('i686' 'x86_64')
+url="http://www.geda-project.org/"
+license=('GPL')
+depends=('gtk2' 'guile' 'libstroke' 'hicolor-icon-theme' 'desktop-file-utils')
+optdepends=('python2: for two of the commands (garchive, tragesym)'
+ 'gawk: for sw2asc')
+conflicts=('geda-gaf')
+provides=('geda-gaf')
+install=geda-gaf.install
+source=(http://ftp.geda-project.org/geda-gaf/unstable/v1.9/$pkgver/${_pkgname}-$pkgver.tar.gz)
+md5sums=('bf8949956e18f34513e503fa1f11f3d5')
+
+prepare() {
+ cd $srcdir/${_pkgname}-$pkgver
+ sed -i '30i#include <locale.h>' gaf/gaf.c
+ sed -i '27i#include <locale.h>' gattrib/src/gattrib.c
+ sed -i '23i#include <locale.h>' gnetlist/src/gnetlist.c
+}
+
+build () {
+ cd $srcdir/${_pkgname}-$pkgver/
+ CFLAGS="-DGLIB_COMPILATION" ./configure --prefix=/usr --disable-update-xdg-database
+ make
+}
+
+package() {
+ cd $srcdir/${_pkgname}-$pkgver/
+ make DESTDIR=$pkgdir/ install
+ sed -i 's+/usr/bin/env python+/usr/bin/env python2+' \
+ $pkgdir/usr/bin/garchive
+ sed -i 's+/usr/bin/python+/usr/bin/python2+' \
+ $pkgdir/usr/bin/tragesym
+ sed -i 's+/usr/bin/python+/usr/bin/python2+' \
+ $pkgdir/usr/share/doc/${_pkgname}/examples/lightning_detector/bom
+}
+
diff --git a/geda-gaf.install b/geda-gaf.install
new file mode 100644
index 000000000000..ad5e587cc694
--- /dev/null
+++ b/geda-gaf.install
@@ -0,0 +1,19 @@
+post_install() {
+if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ echo Updating icon cache...
+ /usr/bin/gtk-update-icon-cache -f -t /usr/share/icons/hicolor
+fi
+if [ -x /usr/bin/update-desktop-database ]; then
+ echo Updating desktop database..
+ /usr/bin/update-desktop-database /usr/share/applications
+fi
+update-mime-database usr/share/mime
+}
+
+post_upgrade() {
+post_install
+}
+
+post_remove() {
+post_install
+} \ No newline at end of file