summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Goto2019-02-07 14:21:13 +0100
committerPhilip Goto2019-02-07 14:21:13 +0100
commit6b165b4af0fdd3c32a1c2a119eda6e603cae5b38 (patch)
tree32c70bfef62e93afde644a201d740b635065e750
parent3fb5223b0e89282b91d89a083e77bd487486de16 (diff)
downloadaur-6b165b4af0fdd3c32a1c2a119eda6e603cae5b38.tar.gz
Update to meson build system
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD21
2 files changed, 12 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d670f20898b1..05f42ec6e60b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gedit-git
pkgdesc = GNOME Text Editor
- pkgver = 3.31.3.r8.g141e7be53
- pkgrel = 2
+ pkgver = 3.31.90.r8.g1a527b41e
+ pkgrel = 1
url = https://wiki.gnome.org/Apps/Gedit
arch = x86_64
groups = gnome
diff --git a/PKGBUILD b/PKGBUILD
index 3ea28d992780..5c4e2af1de0f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: Jan de Groot <jgc@archlinux.org>
pkgname=gedit-git
-pkgver=3.31.3.r8.g141e7be53
-pkgrel=2
+pkgver=3.31.90.r8.g1a527b41e
+pkgrel=1
pkgdesc="GNOME Text Editor"
url="https://wiki.gnome.org/Apps/Gedit"
arch=(x86_64)
@@ -31,18 +31,17 @@ prepare() {
git submodule init
git config --local submodule.libgd.url "$srcdir/libgd"
git submodule update
-
- NOCONFIGURE=1 ./autogen.sh
}
build() {
- cd gedit
- ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --libexecdir=/usr/lib --disable-updater --disable-schemas-compile --enable-python --enable-gtk-doc
- sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
- make
+ arch-meson gedit build -Ddocumentation=true
+ ninja -C build
}
-package(){
- cd gedit
- make DESTDIR="$pkgdir" install
+check() {
+ ninja -C build test
+}
+
+package() {
+ DESTDIR="$pkgdir/" ninja -C build install
}