summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPellegrino Prevete2023-06-29 02:58:13 +0200
committerPellegrino Prevete2023-06-29 02:58:13 +0200
commitfce42b8acb8156d905b9022eed9ff5b87b04d5cf (patch)
tree11554dc85130287f4ef902ed0fd81087cff85833
parent16ca77ad8f3ca3aa36cc79d4ccff44124233cf3f (diff)
downloadaur-fce42b8acb8156d905b9022eed9ff5b87b04d5cf.tar.gz
upgrade to 45
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD66
2 files changed, 57 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 06b9814de932..46899b926588 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gedit-git
pkgdesc = GNOME Text Editor
- pkgver = 3.37.1.r60.g3385da8ee
+ pkgver = 45.0.r1.g8b240c60a
pkgrel = 1
url = https://wiki.gnome.org/Apps/Gedit
arch = i686
@@ -8,20 +8,22 @@ pkgbase = gedit-git
arch = armv7h
arch = aarch64
groups = gnome
+ groups = gnome-git
license = GPL
- makedepends = yelp-tools
- makedepends = vala
- makedepends = gobject-introspection
makedepends = git
+ makedepends = gobject-introspection
makedepends = gtk-doc
makedepends = meson
- depends = gtksourceview4
+ makedepends = vala
+ makedepends = yelp-tools
+ depends = dconf
depends = gsettings-desktop-schemas
- depends = libpeas
depends = gspell
+ depends = gtksourceview4
+ depends = libgedit-gtksourceview
+ depends = libpeas
depends = python-gobject
- depends = dconf
- depends = tepl>5.0.0
+ depends = tepl-git>=6
optdepends = gedit-plugins: Additional features
provides = gedit
conflicts = gedit
@@ -31,4 +33,3 @@ pkgbase = gedit-git
sha256sums = SKIP
pkgname = gedit-git
-
diff --git a/PKGBUILD b/PKGBUILD
index d35e81cf2587..0da71d82f418 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,69 @@
-# Maintainer: Philip Goto <philip.goto@gmail.com>
+# Maintainer: Pellegrino Prevete (tallero) <pellegrinoprevete@gmail.com>
+# Contributor: Philip Goto <philip.goto@gmail.com>
# Contributor: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
# Contributor: Jan de Groot <jgc@archlinux.org>
-pkgname=gedit-git
-pkgver=3.37.1.r60.g3385da8ee
+_pkgname="gedit"
+pkgname="${_pkgname}-git"
+pkgver=45.0.r1.g8b240c60a
pkgrel=1
pkgdesc="GNOME Text Editor"
url="https://wiki.gnome.org/Apps/Gedit"
-arch=(i686 x86_64 armv7h aarch64)
+arch=(
+ i686
+ x86_64
+ armv7h
+ aarch64
+)
license=(GPL)
-depends=(gtksourceview4 gsettings-desktop-schemas libpeas gspell python-gobject dconf 'tepl>5.0.0')
-makedepends=(yelp-tools vala gobject-introspection git gtk-doc meson)
-optdepends=('gedit-plugins: Additional features')
-provides=(gedit)
-conflicts=(gedit)
-groups=(gnome)
-source=("git+https://gitlab.gnome.org/GNOME/gedit.git"
- "git+https://gitlab.gnome.org/GNOME/libgd.git")
-sha256sums=('SKIP'
- 'SKIP')
+depends=(
+ dconf
+ gsettings-desktop-schemas
+ gspell
+ gtksourceview4
+ libgedit-gtksourceview
+ libpeas
+ python-gobject
+ 'tepl-git>=6')
+makedepends=(
+ git
+ gobject-introspection
+ gtk-doc
+ meson
+ vala
+ yelp-tools
+)
+optdepends=(
+ 'gedit-plugins: Additional features'
+)
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+groups=(gnome gnome-git)
+source=(
+ "git+https://gitlab.gnome.org/GNOME/gedit.git"
+ "git+https://gitlab.gnome.org/GNOME/libgd.git"
+)
+sha256sums=(
+ 'SKIP'
+ 'SKIP'
+)
pkgver() {
- cd gedit
+ cd "${_pkgname}"
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd gedit
+ cd "${_pkgname}"
git submodule init
- git config --local submodule.libgd.url "$srcdir/libgd"
+ git config --local submodule.libgd.url "${srcdir}/libgd"
git submodule update
}
build() {
arch-meson gedit build -D gtk_doc=true
- ninja -C build
+ meson compile -C build
}
check() {
@@ -43,5 +71,5 @@ check() {
}
package() {
- DESTDIR="$pkgdir" meson install -C build
+ meson install -C build --destdir "${pkgdir}"
}