summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Goto2019-01-01 15:40:15 +0100
committerPhilip Goto2019-01-01 15:40:15 +0100
commitfd38f52bc8621477972ad7cb3c40eb06418721cb (patch)
tree7ed0611252dc8fa7cf7f230e1c0c8668538ba1bc
downloadaur-fd38f52bc8621477972ad7cb3c40eb06418721cb.tar.gz
Initialize package
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD48
2 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..172fb29a2149
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = gedit-git
+ pkgdesc = GNOME Text Editor
+ pkgver = 3.31.3.r8.g141e7be53
+ pkgrel = 1
+ url = https://wiki.gnome.org/Apps/Gedit
+ arch = x86_64
+ groups = gnome
+ license = GPL
+ makedepends = yelp-tools
+ makedepends = intltool
+ makedepends = vala
+ makedepends = gobject-introspection
+ makedepends = gnome-common
+ makedepends = git
+ makedepends = gtk-doc
+ depends = gtksourceview3
+ depends = gsettings-desktop-schemas
+ depends = libpeas
+ depends = gspell
+ depends = python-gobject
+ depends = dconf
+ optdepends = gedit-plugins: Additional features
+ provides = gedit
+ conflicts = gedit
+ source = git+https://gitlab.gnome.org/GNOME/gedit.git
+ source = git+https://gitlab.gnome.org/GNOME/libgd.git
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = gedit-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..44d9b53e04cc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Philip Goto <philip.goto@gmail.com>
+# Contributor: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# Contributor: Jan de Groot <jgc@archlinux.org>
+
+pkgname=gedit-git
+pkgver=3.31.3.r8.g141e7be53
+pkgrel=1
+pkgdesc="GNOME Text Editor"
+url="https://wiki.gnome.org/Apps/Gedit"
+arch=(x86_64)
+license=(GPL)
+depends=(gtksourceview3 gsettings-desktop-schemas libpeas gspell python-gobject dconf)
+makedepends=(yelp-tools intltool vala gobject-introspection gnome-common git gtk-doc)
+provides=(gedit)
+conflicts=(gedit)
+optdepends=('gedit-plugins: Additional features')
+groups=(gnome)
+source=("git+https://gitlab.gnome.org/GNOME/gedit.git"
+ "git+https://gitlab.gnome.org/GNOME/libgd.git")
+sha256sums=('SKIP'
+ 'SKIP')
+
+pkgver() {
+ cd gedit
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd gedit
+
+ git submodule init
+ git config --local submodule.libgd.url "$srcdir/libgd"
+ git submodule update
+
+ NOCONFIGURE=1 ./autogen.sh
+}
+
+build() {
+ cd gedit
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --libexecdir=/usr/lib --disable-updater --disable-schemas-compile --enable-python --enable-gtk-doc
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+ make
+}
+
+package(){
+ cd gedit
+ make DESTDIR="$pkgdir" install
+}