summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Weiman2015-08-16 11:33:34 -0400
committerMark Weiman2015-08-16 11:33:34 -0400
commita45763fa4b2c337ad85b88bab8da01bdcd47ef32 (patch)
treed27d905bc72cb5f343d61cc2a775e38b92d53ebe
downloadaur-a45763fa4b2c337ad85b88bab8da01bdcd47ef32.tar.gz
initial import
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD43
-rw-r--r--gschemas.install12
3 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ef38527471a6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = gedit-latex
+ pkgdesc = Gedit plugin that provides features to ease the edition of LaTeX documents
+ pkgver = 3.8.0
+ pkgrel = 1
+ url = https://wiki.gnome.org/Apps/Gedit/LaTeXPlugin
+ install = gschemas.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = cairo
+ makedepends = gettext
+ makedepends = atk
+ makedepends = intltool
+ makedepends = libpeas
+ makedepends = gtk3
+ makedepends = glib2
+ depends = gedit
+ depends = rubber
+ depends = texlive-core
+ depends = python-gobject
+ depends = python-dbus
+ conflicts = gedit-latex-plugin
+ replaces = gedit-latex-plugin
+ source = http://ftp.gnome.org/pub/GNOME/sources/gedit-latex/3.8/gedit-latex-3.8.0.tar.xz
+ sha256sums = 1a49a57b650e0af446299ba70b237d9066650f21ff938390d5b6261430061309
+
+pkgname = gedit-latex
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2c11357f1e49
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Contributor: Aleksei Lissitsin <aleksei.lissitsin@gmail.com>
+pkgname=gedit-latex
+pkgver=3.8.0
+pkgrel=1
+pkgdesc="Gedit plugin that provides features to ease the edition of LaTeX documents"
+arch=('i686' 'x86_64')
+url="https://wiki.gnome.org/Apps/Gedit/LaTeXPlugin"
+license=('GPL')
+groups=()
+depends=(gedit rubber texlive-core python-gobject python-dbus)
+makedepends=(cairo gettext atk intltool libpeas gtk3 glib2)
+provides=()
+conflicts=(gedit-latex-plugin)
+replaces=(gedit-latex-plugin)
+install=gschemas.install
+source=(http://ftp.gnome.org/pub/GNOME/sources/gedit-latex/3.8/gedit-latex-3.8.0.tar.xz)
+sha256sums=('1a49a57b650e0af446299ba70b237d9066650f21ff938390d5b6261430061309')
+build() {
+ cd "$srcdir"
+
+ ln -sf gedit-latex "$pkgname-$pkgver"
+
+ cd "$pkgname-$pkgver"
+
+ # fixes taken from the fedora package
+ sed -i -e 's|_CONFIG_FILENAME = "/etc/texmf/texmf.cnf"|_CONFIG_FILENAME = "/usr/share/texmf/web2c/texmf.cnf"|' latex/latex/environment.py
+ sed -i -e 's|_DEFAULT_TEXMF_DIR = "/usr/share/texmf-texlive"|_DEFAULT_TEXMF_DIR = "/usr/share/texmf"|' latex/latex/environment.py
+
+ # fixes some path errors on loading
+ sed -i -e 's|cnf_file\[key\]|cnf_file\[key\].replace("$TEXMFROOT", "/usr/share")|' latex/latex/environment.py
+
+ # this is needed when building from git src
+ #./autogen.sh
+
+ ./configure --prefix=/usr --disable-static
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}
+
diff --git a/gschemas.install b/gschemas.install
new file mode 100644
index 000000000000..30ca15725dbe
--- /dev/null
+++ b/gschemas.install
@@ -0,0 +1,12 @@
+post_install() {
+ /usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas/
+}
+
+post_upgrade() {
+ /usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas/
+}
+
+post_remove() {
+ /usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas/
+}
+