summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMubashshir2024-05-03 03:03:34 +0600
committerMubashshir2024-05-03 03:23:47 +0600
commit09c77a9ab4c288db020c47aef412952ed3dfe31e (patch)
treecaea7a93c33b7b98ce8aa35bb82f1828deac7604
parent017f732e433d05df7ef3be8bf889a8f02e5828be (diff)
downloadaur-09c77a9ab4c288db020c47aef412952ed3dfe31e.tar.gz
gnome/gedit: Release 47.0-1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD8
-rw-r--r--menubar.patch30
3 files changed, 24 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 87d0e5159592..9f99ae991357 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gedit-menubar
pkgdesc = GNOME Text Editor (Patched to show menubar)
- pkgver = 46.2
+ pkgver = 47.0
pkgrel = 1
url = https://wiki.gnome.org/Apps/Gedit
arch = x86_64
@@ -19,16 +19,16 @@ pkgbase = gedit-menubar
depends = libgedit-amtk
depends = libpeas
depends = python-gobject
- depends = tepl
+ depends = libgedit-tepl
optdepends = gedit-plugins: Additional features
provides = gedit
conflicts = gedit-code-assistance<=3.16.0+4+gd19b879-1
conflicts = gedit
- source = git+https://gitlab.gnome.org/GNOME/gedit.git#tag=46.2
+ source = git+https://gitlab.gnome.org/GNOME/gedit.git#tag=47.0
source = git+https://gitlab.gnome.org/GNOME/libgd.git
source = menubar.patch
+ sha256sums = fe9f6e5acb3a6dff0c8d6ea150eb85b3923e05acb4ce10c4b3e65c04f049895a
sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = a711518646e2d0727927ea88d59010ece1611f1e00436a7276f934a628491c6a
+ sha256sums = 80692c1e39bc59f997f7d6857fc7b7d65a94aa53ff0f20de6e633a3596b20163
pkgname = gedit-menubar
diff --git a/PKGBUILD b/PKGBUILD
index 92289d004b6b..36212030d2e2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# match! alpha[0-9]*$
pkgname=gedit-menubar
-pkgver=46.2
+pkgver=47.0
pkgrel=1
pkgdesc="GNOME Text Editor (Patched to show menubar)"
url="https://wiki.gnome.org/Apps/Gedit"
@@ -16,7 +16,7 @@ depends=(
libgedit-amtk
libpeas
python-gobject
- tepl
+ libgedit-tepl
)
makedepends=(
appstream-glib
@@ -36,9 +36,9 @@ groups=(gnome-extra)
source=("git+https://gitlab.gnome.org/GNOME/gedit.git#tag=$pkgver"
"git+https://gitlab.gnome.org/GNOME/libgd.git"
"menubar.patch")
-sha256sums=('SKIP'
+sha256sums=('fe9f6e5acb3a6dff0c8d6ea150eb85b3923e05acb4ce10c4b3e65c04f049895a'
'SKIP'
- 'a711518646e2d0727927ea88d59010ece1611f1e00436a7276f934a628491c6a')
+ '80692c1e39bc59f997f7d6857fc7b7d65a94aa53ff0f20de6e633a3596b20163')
pkgver() {
git -C ${pkgname%-*} describe --tags | sed 's/-/+/g'
diff --git a/menubar.patch b/menubar.patch
index 4e6727e6b771..81298bd54ad3 100644
--- a/menubar.patch
+++ b/menubar.patch
@@ -1,8 +1,8 @@
diff --git a/gedit/gedit-app.c b/gedit/gedit-app.c
-index 9ddac418d..d1cbd0dae 100644
+index 77faf73e5..55ece43a0 100644
--- a/gedit/gedit-app.c
+++ b/gedit/gedit-app.c
-@@ -641,6 +641,7 @@ add_accelerator (GtkApplication *app,
+@@ -640,6 +640,7 @@ add_accelerator (GtkApplication *app,
static gboolean
show_menubar (void)
{
@@ -10,19 +10,19 @@ index 9ddac418d..d1cbd0dae 100644
GtkSettings *settings = gtk_settings_get_default ();
gboolean result;
-@@ -1172,6 +1173,7 @@ gedit_app_create_window_impl (GeditApp *app)
- GeditWindow *window;
-
- window = g_object_new (GEDIT_TYPE_WINDOW, "application", app, NULL);
+@@ -1175,6 +1176,7 @@ gedit_app_create_window_impl (GeditApp *app)
+ window = g_object_new (GEDIT_TYPE_WINDOW,
+ "application", app,
+ NULL);
+ _gedit_window_set_menu_bar_from_app (window, GTK_APPLICATION(app));
- gedit_debug_message (DEBUG_APP, "Window created");
-
+ g_signal_connect (window,
+ "delete-event",
diff --git a/gedit/gedit-window.c b/gedit/gedit-window.c
-index 930899bb5..968eccc30 100644
+index 8ef331e95..dd719ec10 100644
--- a/gedit/gedit-window.c
+++ b/gedit/gedit-window.c
-@@ -2781,6 +2781,34 @@ gedit_window_init (GeditWindow *window)
+@@ -2636,6 +2636,34 @@ gedit_window_init (GeditWindow *window)
gedit_debug_message (DEBUG_WINDOW, "END");
}
@@ -58,16 +58,16 @@ index 930899bb5..968eccc30 100644
* gedit_window_get_active_view:
* @window: a #GeditWindow.
diff --git a/gedit/gedit-window.h b/gedit/gedit-window.h
-index 8417cb1b2..1c1d9608d 100644
+index 176c85adf..7a52ebf81 100644
--- a/gedit/gedit-window.h
+++ b/gedit/gedit-window.h
-@@ -152,6 +152,9 @@ GList *_gedit_window_get_all_tabs (GeditWindow *window);
-
- GFile *_gedit_window_pop_last_closed_doc (GeditWindow *window);
+@@ -167,6 +167,9 @@ GList * _gedit_window_get_all_tabs (GeditWindow *window);
+ G_GNUC_INTERNAL
+ GFile * _gedit_window_pop_last_closed_doc (GeditWindow *window);
+void _gedit_window_set_menu_bar_from_app (GeditWindow *window,
+ GtkApplication *app);
+
G_END_DECLS
- #endif /* GEDIT_WINDOW_H */
+ #endif /* GEDIT_WINDOW_H */