summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMubashshir2020-11-21 16:13:40 +0600
committerMubashshir2020-11-21 16:13:40 +0600
commit3d2b3efc830ae5e7dbee4fc39d9beb9ffb15cbb8 (patch)
treebb664fcc130f4d038db23fd2e929758ffee9e211
downloadaur-3d2b3efc830ae5e7dbee4fc39d9beb9ffb15cbb8.tar.gz
init
-rw-r--r--.SRCINFO37
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD53
-rw-r--r--menubar.patch12
4 files changed, 106 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..173e50aa1d87
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,37 @@
+pkgbase = gedit-menubar
+ pkgdesc = GNOME Text Editor
+ pkgver = 3.38.1
+ pkgrel = 1
+ url = https://wiki.gnome.org/Apps/Gedit
+ arch = x86_64
+ groups = gnome
+ license = GPL
+ makedepends = yelp-tools
+ makedepends = vala
+ makedepends = gobject-introspection
+ makedepends = git
+ makedepends = gtk-doc
+ makedepends = meson
+ makedepends = appstream-glib
+ makedepends = desktop-file-utils
+ makedepends = libxml2
+ depends = gtksourceview4
+ depends = gsettings-desktop-schemas
+ depends = libpeas
+ depends = gspell
+ depends = python-gobject
+ depends = dconf
+ depends = tepl
+ optdepends = gedit-plugins: Additional features
+ provides = gedit
+ conflicts = gedit-code-assistance<=3.16.0+4+gd19b879-1
+ conflicts = gedit
+ source = git+https://gitlab.gnome.org/GNOME/gedit.git#tag=3.38.1
+ source = git+https://gitlab.gnome.org/GNOME/libgd.git
+ source = menubar.patch
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = 7b7bbcf115ee7a755ef039676a799bd0d2a95c36f4793e484bf296823efb2c32
+
+pkgname = gedit-menubar
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1850446bbe76
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.SRCINFO
+!PKGBUILD
+!menubar.patch
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..224de5c3875e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Ahmad Hasan Mubashshir <ahmubashshir@gmail.com>
+# pkg: gitlab GNOME/gedit gitlab.gnome.org
+
+pkgname=gedit-menubar
+pkgver=3.38.1
+pkgrel=1
+pkgdesc="GNOME Text Editor"
+url="https://wiki.gnome.org/Apps/Gedit"
+arch=(x86_64)
+license=(GPL)
+depends=(gtksourceview4 gsettings-desktop-schemas libpeas gspell python-gobject
+ dconf tepl)
+makedepends=(yelp-tools vala gobject-introspection git gtk-doc meson
+ appstream-glib desktop-file-utils libxml2)
+optdepends=('gedit-plugins: Additional features')
+conflicts=('gedit-code-assistance<=3.16.0+4+gd19b879-1' 'gedit')
+provides=('gedit')
+groups=(gnome)
+
+source=("git+https://gitlab.gnome.org/GNOME/gedit.git#tag=$pkgver"
+ "git+https://gitlab.gnome.org/GNOME/libgd.git"
+ "menubar.patch")
+sha256sums=('SKIP'
+ 'SKIP'
+ '7b7bbcf115ee7a755ef039676a799bd0d2a95c36f4793e484bf296823efb2c32')
+
+pkgver() {
+ cd ${pkgname%-*}
+ git describe --tags | sed 's/-/+/g'
+}
+
+prepare() {
+ cd ${pkgname%-*}
+ git submodule init
+ git submodule set-url subprojects/libgd "$srcdir/libgd"
+ git submodule update
+ patch -p1 < "$srcdir/menubar.patch"
+}
+
+build() {
+ arch-meson ${pkgname%-*} build \
+ -D gtk_doc=true \
+ -D require_all_tests=true
+ meson compile -C build
+}
+
+check() {
+ meson test -C build --print-errorlogs
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+}
diff --git a/menubar.patch b/menubar.patch
new file mode 100644
index 000000000000..ad3cc58c592f
--- /dev/null
+++ b/menubar.patch
@@ -0,0 +1,12 @@
+diff --git a/gedit/gedit-app.c b/gedit/gedit-app.c
+index 5532d5975..671208c35 100644
+--- a/gedit/gedit-app.c
++++ b/gedit/gedit-app.c
+@@ -627,6 +627,7 @@ add_accelerator (GtkApplication *app,
+ static gboolean
+ show_menubar (void)
+ {
++ return TRUE;
+ GtkSettings *settings = gtk_settings_get_default ();
+ gboolean result;
+