summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-06-11 22:18:03 -0600
committerMark Wagie2021-06-11 22:18:03 -0600
commit548d591e05ace877e5433eb571c07c34a8568a9b (patch)
tree60721733fc14756430c6430ee06c4fdbfbdab04f
downloadaur-548d591e05ace877e5433eb571c07c34a8568a9b.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD28
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8553ec203ef1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = gedit-plugin-markdown_preview
+ pkgdesc = A gedit plugin previewing markdown (.md) documents
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/maoschanz/gedit-plugin-markdown_preview
+ arch = any
+ license = GPL3
+ depends = gedit
+ depends = python-markdown
+ depends = webkit2gtk
+ optdepends = pymdown-extensions: extra Python Markdown extensions
+ optdepends = python-pygments: for CodeHilite extension
+ optdepends = pandoc: export and stylesheet support
+ optdepends = texlive-bin: export to PDF with pandoc
+ optdepends = texlive-core: export to PDF with pandoc
+ source = gedit-plugin-markdown_preview-1.0.tar.gz::https://github.com/maoschanz/gedit-plugin-markdown_preview/archive/refs/tags/1.0.tar.gz
+ sha256sums = 46eb4252628c2df8ba375b49f7b10b4a4b880d9213c2d1979796565e03ddc24d
+
+pkgname = gedit-plugin-markdown_preview
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4dab8d6386e3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a9db77fe51a0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+pkgname=gedit-plugin-markdown_preview
+pkgver=1.0
+pkgrel=1
+pkgdesc="A gedit plugin previewing markdown (.md) documents"
+arch=('any')
+url="https://github.com/maoschanz/gedit-plugin-markdown_preview"
+license=('GPL3')
+depends=('gedit' 'python-markdown' 'webkit2gtk')
+optdepends=('pymdown-extensions: extra Python Markdown extensions'
+ 'python-pygments: for CodeHilite extension'
+ 'pandoc: export and stylesheet support'
+ 'texlive-bin: export to PDF with pandoc'
+ 'texlive-core: export to PDF with pandoc')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/$pkgver.tar.gz")
+sha256sums=('46eb4252628c2df8ba375b49f7b10b4a4b880d9213c2d1979796565e03ddc24d')
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm644 org.gnome.gedit.plugins.markdown_preview.gschema.xml -t \
+ "$pkgdir/usr/share/glib-2.0/schemas"
+ install -Dm644 markdown_preview.plugin -t "$pkgdir/usr/lib/gedit/plugins"
+ cp -r markdown_preview "$pkgdir/usr/lib/gedit/plugins"
+ install -Dm644 example.css -t "$pkgdir/usr/share/doc/$pkgname"
+
+ rm "$pkgdir/usr/lib/gedit/plugins/markdown_preview/locale/gedit-plugin-markdown-preview.pot"
+ rm "$pkgdir"/usr/lib/gedit/plugins/markdown_preview/locale/{fr,nl}/LC_MESSAGES/*.po
+}