summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-04-22 22:38:51 +0800
committerzxp198210052023-04-22 22:38:51 +0800
commit1f8d16f9b97ef6b2eddc0a97fa77ea07e1cdb2d9 (patch)
tree2943007e25b1327b3bf8449538f30686a1eeb6cd
parenta49ce911165036479e727916d749f9e296ff66a1 (diff)
downloadaur-1f8d16f9b97ef6b2eddc0a97fa77ea07e1cdb2d9.tar.gz
fix errors
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD18
2 files changed, 13 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b2671dd147c8..51809ba235c2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -14,9 +14,6 @@ pkgbase = geekeditor-bin
depends = libdrm
depends = mesa
depends = libxrandr
- depends = hicolor-icon-theme
- depends = libxkbcommon
- depends = cairo
depends = libxcomposite
depends = nspr
depends = glibc
@@ -32,7 +29,11 @@ pkgbase = geekeditor-bin
depends = dbus
depends = libcups
depends = sh
+ depends = hicolor-icon-theme
+ depends = libxkbcommon
+ depends = cairo
conflicts = geekeditor
+ options = !strip
source = geekeditor-1.4.9.deb::https://github.com/geekeditor/geekeditor-releases/releases/download/v1.4.9/geekeditor_1.4.9_amd64.deb
sha256sums = 99c69e953535adffd4edda3932d3f12acb206f104de3dddb15a04b656fda1a1a
diff --git a/PKGBUILD b/PKGBUILD
index 66a6f9ecee2f..5f197fd60bf5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,5 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
-_pkgname=geekeditor
-pkgname="${_pkgname}-bin"
+pkgname="geekeditor-bin"
_appname=GeekEditor
pkgver=1.4.9
pkgrel=3
@@ -8,14 +7,15 @@ pkgdesc="Immersive efficiency writing editor.极客编辑器是一款所见即
arch=('x86_64')
url="https://github.com/geekeditor/geekeditor-releases"
license=('GPL3')
-conflicts=("${_pkgname}")
-depends=(alsa-lib nodejs gtk3 at-spi2-core nss libxfixes libdrm mesa libxrandr hicolor-icon-theme libxkbcommon cairo \
- libxcomposite nspr glibc libxext expat gdk-pixbuf2 libx11 glib2 libxcb gcc-libs pango libxdamage dbus libcups sh)
-options=()
-source=("${_pkgname}-${pkgver}.deb::${url}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_amd64.deb")
+conflicts=("${pkgname%-bin}")
+depends=('alsa-lib' 'nodejs' 'gtk3' 'at-spi2-core' 'nss' 'libxfixes' 'libdrm' 'mesa' 'libxrandr' \
+ 'libxcomposite' 'nspr' 'glibc' 'libxext' 'expat' 'gdk-pixbuf2' 'libx11' 'glib2' 'libxcb' 'gcc-libs' \
+ 'pango' 'libxdamage' 'dbus' 'libcups' 'sh' 'hicolor-icon-theme' 'libxkbcommon' 'cairo')
+options=(!strip)
+source=("${pkgname%-bin}-${pkgver}.deb::${url}/releases/download/v${pkgver}/${pkgname%-bin}_${pkgver}_amd64.deb")
sha256sums=('99c69e953535adffd4edda3932d3f12acb206f104de3dddb15a04b656fda1a1a')
package() {
bsdtar -xvf data.tar.xz -C "${pkgdir}"
rm -r "${pkgdir}/opt/${_appname}/resources/app/node_modules/ajv/scripts/info" \
- "${pkgdir}/opt/${_appname}/resources/app/node_modules/he/man/he.1"
-} \ No newline at end of file
+ "${pkgdir}/opt/${_appname}/resources/app/node_modules/he/man"
+}