summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-09-12 18:14:05 +0800
committerzxp198210052023-09-12 18:14:05 +0800
commit4046b4859dfd81db35243a4d645ef0b8bae164be (patch)
tree33f6bba056093475f3b64ec968fb5b344abbe17f
parentae1cc3eb153700da34905fe2a20c39057b16fa8d (diff)
downloadaur-4046b4859dfd81db35243a4d645ef0b8bae164be.tar.gz
fix errors
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD18
2 files changed, 16 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bbf821f54cda..0f7362f48dc4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = geekeditor-bin
pkgdesc = Immersive efficiency writing editor.极客编辑器是一款所见即所得(WYSIWYG)富文本沉浸式写作排版编辑器,注重高效创作,可多开文档编辑,同时支持Markdown语法输入及一键排版
pkgver = 1.4.9
- pkgrel = 4
+ pkgrel = 5
url = https://github.com/geekeditor/geekeditor-releases
arch = x86_64
license = GPL3
diff --git a/PKGBUILD b/PKGBUILD
index be0142b6b986..76130b7c350e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=geekeditor-bin
-_appname=GeekEditor
+_pkgname=GeekEditor
pkgver=1.4.9
-pkgrel=4
+pkgrel=5
pkgdesc="Immersive efficiency writing editor.极客编辑器是一款所见即所得(WYSIWYG)富文本沉浸式写作排版编辑器,注重高效创作,可多开文档编辑,同时支持Markdown语法输入及一键排版"
arch=('x86_64')
url="https://github.com/geekeditor/geekeditor-releases"
@@ -13,6 +13,18 @@ depends=('alsa-lib' 'gtk3' 'at-spi2-core' 'nss' 'libxfixes' 'libdrm' 'mesa' 'lib
'expat' 'gdk-pixbuf2' 'libx11' 'glib2' 'libxcb' 'gcc-libs' 'pango' 'libxdamage' 'dbus' 'libcups' 'sh' 'hicolor-icon-theme' 'libxkbcommon')
source=("${pkgname%-bin}-${pkgver}.deb::${url}/releases/download/v${pkgver}/${pkgname%-bin}_${pkgver}_amd64.deb")
sha256sums=('99c69e953535adffd4edda3932d3f12acb206f104de3dddb15a04b656fda1a1a')
+prepare() {
+ bsdtar -xf "${srcdir}/data.tar.xz"
+ sed "s|/opt/${_pkgname}/${_pkgname}|${pkgname%-bin} --no-sandbox|g;s|Icon=${_pkgname}|Icon=${pkgname%-bin}|g;s|Writing Editor|Office|g" \
+ -i "${srcdir}/usr/share/applications/${_pkgname}.desktop"
+}
package() {
- bsdtar -xf data.tar.xz -C "${pkgdir}"
+ install -Dm755 -d "${pkgdir}/"{opt/"${pkgname%-bin}",usr/bin}
+ cp -r "${srcdir}/opt/${_pkgname}/"* "${pkgdir}/opt/${pkgname%-bin}"
+ ln -sf "/opt/${pkgname%-bin}/${_pkgname}" "${pkgdir}/usr/bin/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/usr/share/applications/${_pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname%-bin}.desktop"
+ for _icons in 16x16 32x32 48x48 64x64 128x128 256x256 512x512 1024x1024;do
+ install -Dm644 "${srcdir}/usr/share/icons/hicolor/${_icons}/apps/${_pkgname}.png" \
+ "${pkgdir}/usr/share/icons/hicolor/${_icons}/apps/${pkgname%-bin}.png"
+ done
} \ No newline at end of file