summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-11-14 12:08:29 +0800
committerzxp198210052023-11-14 12:08:29 +0800
commitcbaf7a40076b1ea27e61941ee4996b74da803d19 (patch)
tree8bac619b05ce3eedd5ff6b5269eeb28bbc55d5a0
parent4046b4859dfd81db35243a4d645ef0b8bae164be (diff)
downloadaur-cbaf7a40076b1ea27e61941ee4996b74da803d19.tar.gz
fix errors
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD37
2 files changed, 33 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0f7362f48dc4..360e52fd7415 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = geekeditor-bin
pkgdesc = Immersive efficiency writing editor.极客编辑器是一款所见即所得(WYSIWYG)富文本沉浸式写作排版编辑器,注重高效创作,可多开文档编辑,同时支持Markdown语法输入及一键排版
pkgver = 1.4.9
- pkgrel = 5
- url = https://github.com/geekeditor/geekeditor-releases
+ pkgrel = 6
+ url = https://www.geekeditor.com/
arch = x86_64
license = GPL3
depends = alsa-lib
@@ -15,20 +15,16 @@ pkgbase = geekeditor-bin
depends = libxrandr
depends = libxcomposite
depends = nspr
- depends = glibc
depends = libxext
depends = cairo
depends = expat
depends = gdk-pixbuf2
depends = libx11
- depends = glib2
depends = libxcb
- depends = gcc-libs
depends = pango
depends = libxdamage
depends = dbus
depends = libcups
- depends = sh
depends = hicolor-icon-theme
depends = libxkbcommon
provides = geekeditor=1.4.9
diff --git a/PKGBUILD b/PKGBUILD
index 76130b7c350e..c283496f225d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,43 @@
pkgname=geekeditor-bin
_pkgname=GeekEditor
pkgver=1.4.9
-pkgrel=5
+pkgrel=6
pkgdesc="Immersive efficiency writing editor.极客编辑器是一款所见即所得(WYSIWYG)富文本沉浸式写作排版编辑器,注重高效创作,可多开文档编辑,同时支持Markdown语法输入及一键排版"
arch=('x86_64')
-url="https://github.com/geekeditor/geekeditor-releases"
+url=https://www.geekeditor.com/
+_ghurl="https://github.com/geekeditor/geekeditor-releases"
license=('GPL3')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
-depends=('alsa-lib' 'gtk3' 'at-spi2-core' 'nss' 'libxfixes' 'libdrm' 'mesa' 'libxrandr' 'libxcomposite' 'nspr' 'glibc' 'libxext' 'cairo' \
- 'expat' 'gdk-pixbuf2' 'libx11' 'glib2' 'libxcb' 'gcc-libs' 'pango' 'libxdamage' 'dbus' 'libcups' 'sh' 'hicolor-icon-theme' 'libxkbcommon')
-source=("${pkgname%-bin}-${pkgver}.deb::${url}/releases/download/v${pkgver}/${pkgname%-bin}_${pkgver}_amd64.deb")
+depends=(
+ 'alsa-lib'
+ 'gtk3'
+ 'at-spi2-core'
+ 'nss'
+ 'libxfixes'
+ 'libdrm'
+ 'mesa'
+ 'libxrandr'
+ 'libxcomposite'
+ 'nspr'
+ 'libxext'
+ 'cairo'
+ 'expat'
+ 'gdk-pixbuf2'
+ 'libx11'
+ 'libxcb'
+ 'pango'
+ 'libxdamage'
+ 'dbus'
+ 'libcups'
+ 'hicolor-icon-theme'
+ 'libxkbcommon'
+)
+source=(
+ "${pkgname%-bin}-${pkgver}.deb::${_ghurl}/releases/download/v${pkgver}/${pkgname%-bin}_${pkgver}_amd64.deb"
+)
sha256sums=('99c69e953535adffd4edda3932d3f12acb206f104de3dddb15a04b656fda1a1a')
-prepare() {
+build() {
bsdtar -xf "${srcdir}/data.tar.xz"
sed "s|/opt/${_pkgname}/${_pkgname}|${pkgname%-bin} --no-sandbox|g;s|Icon=${_pkgname}|Icon=${pkgname%-bin}|g;s|Writing Editor|Office|g" \
-i "${srcdir}/usr/share/applications/${_pkgname}.desktop"