summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSterophonick2024-04-03 11:24:53 -0600
committerSterophonick2024-04-03 11:24:53 -0600
commitd43948df3263004b2ba6a78ce7ec99fd93a65e48 (patch)
tree9dea1e3ed9115976b4db222508c2523c7e5013be
downloadaur-d43948df3263004b2ba6a78ce7ec99fd93a65e48.tar.gz
init
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD43
-rwxr-xr-xgeepee3239
-rw-r--r--geepee32.desktop10
-rw-r--r--geepee32.pngbin0 -> 2862 bytes
5 files changed, 109 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..15aa8677668c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = geepee32
+ pkgdesc = Windows application to emulate the GamePark GP32 system.
+ pkgver = 0.44
+ pkgrel = 1
+ url = https://www.schuerewegen.tk/gp32/
+ arch = x86_64
+ arch = i686
+ makedepends = unzip
+ depends = wine
+ source = https://www.schuerewegen.tk/download/geepee32_044_win32_directx.zip
+ source = geepee32
+ source = geepee32.desktop
+ source = geepee32.png
+ md5sums = a095dfdc88596e7f356d7a71d8030491
+
+pkgname = geepee32
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4eb5eb0095c1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Sterophonick
+pkgname=geepee32
+_pkgname='geepee32'
+pkgver=0.44
+pkgrel=1
+pkgdesc='Windows application to emulate the GamePark GP32 system.'
+url='https://www.schuerewegen.tk/gp32/'
+arch=(x86_64 i686)
+depends=('wine')
+makedepends=('unzip')
+filename=geepee32_044_win32_directx
+source=(https://www.schuerewegen.tk/download/geepee32_044_win32_directx.zip
+ geepee32
+ geepee32.desktop
+ geepee32.png)
+md5sums=('a095dfdc88596e7f356d7a71d8030491'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
+noextract=("geepee32_044_win32_directx.zip")
+
+prepare() {
+ mkdir -p $filename
+ unzip -o -d $filename $filename.zip
+}
+
+package() {
+ cd $srcdir
+ install -Dm755 geepee32 $pkgdir/usr/bin/geepee32
+ install -Dm644 geepee32.desktop $pkgdir/usr/share/applications/geepee32.desktop
+ install -Dm644 geepee32.png $pkgdir/usr/share/pixmaps/geepee32.png
+
+ mkdir -p $pkgdir/usr/share/geepee32
+
+ cp -r $srcdir/$filename/* $pkgdir/usr/share/geepee32
+
+ rm -rf $pkgdir/usr/share/geepee32/system/gp32/config
+ rm -rf $pkgdir/usr/share/geepee32/system/gp32/firmware
+ rm -rf $pkgdir/usr/share/geepee32/system/gp32/log
+ rm -rf $pkgdir/usr/share/geepee32/system/gp32/screenshot
+
+ chmod -R 777 $pkgdir/usr/share/geepee32
+}
diff --git a/geepee32 b/geepee32
new file mode 100755
index 000000000000..714e52537b41
--- /dev/null
+++ b/geepee32
@@ -0,0 +1,39 @@
+#!/bin/bash
+
+export WINEPREFIX=~/.geepee32/pfx
+
+mkdir -p ~/.geepee32/ ~/.geepee32/config ~/.geepee32/firmware ~/.geepee32/log ~/.geepee32/screenshot
+ln -sfn ~/.geepee32/config /usr/share/geepee32/system/gp32/config
+ln -sfn ~/.geepee32/firmware /usr/share/geepee32/system/gp32/firmware
+ln -sfn ~/.geepee32/log /usr/share/geepee32/system/gp32/log
+ln -sfn ~/.geepee32/screenshot /usr/share/geepee32/system/gp32/screenshot
+
+if [ ! -f ~/.geepee32/config/memory.def ]; then
+ cat > ~/.geepee32/config/memory.def << EOF
+ 00000000 00080000 FIRMWARE
+ 0C000000 00800000 RAM
+ 14000000 00000100 MEMORY CONTROLLER
+ 14200000 00000100 USB HOST CONTROLLER
+ 14400000 00000100 INTERRUPT CONTROLLER
+ 14600000 00000100 DMA
+ 14800000 00000100 CLOCK & POWER MANAGEMENT
+ 14A00000 00000800 LCD CONTROLLER
+ 15000000 00000100 UART 0
+ 15004000 00000100 UART 1
+ 15100000 00000100 PWM TIMER
+ 15200000 00000200 USB DEVICE
+ 15300000 00000100 WATCHDOG TIMER
+ 15400000 00000100 IIC
+ 15400100 00002000 IIC (EEPROM DATA)
+ 15508000 00000100 IIS
+ 15600000 00000100 I/O PORT
+ 15700000 00000100 RTC
+ 15800000 00000100 A/D CONVERTER
+ 15900000 00000100 SPI
+ 15A00000 00000100 MMC INTERFACE
+EOF
+fi
+
+
+# WINE Launcher script for GeePee32 Emulator
+wine /usr/share/geepee32/geepee32.exe
diff --git a/geepee32.desktop b/geepee32.desktop
new file mode 100644
index 000000000000..3a7dd3b4ca74
--- /dev/null
+++ b/geepee32.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Encoding=UTF-8
+Type=Application
+Name=GeePee32
+Comment=Windows application to emulate the GamePark GP32 system.
+Exec=geepee32
+Icon=geepee32
+Terminal=false
+StartupNotify=false
+Categories=Wine;Game;Emulator;
diff --git a/geepee32.png b/geepee32.png
new file mode 100644
index 000000000000..d216af43cfac
--- /dev/null
+++ b/geepee32.png
Binary files differ