summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpezcurrel2019-08-05 12:08:25 +0200
committerpezcurrel2019-08-05 12:08:25 +0200
commit56054b22e3aca711f412834c5be2e866a3d3dcce (patch)
treeec135e6a940a09b09754566887a41897d21514f5
parent26931b52d9c0c89a37178347d4453fad829faa66 (diff)
downloadaur-geeqie-lirc.tar.gz
Upgrade to 1.5
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
2 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e81bd958d4bb..80e40305e0dd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = geeqie-lirc
- pkgdesc = A lightweight image browser and viewer with LIRC support
- pkgver = 1.4
+ pkgdesc = Lightweight image browser and viewer with LIRC support
+ pkgver = 1.5
pkgrel = 1
url = http://www.geeqie.org/
arch = x86_64
@@ -17,9 +17,9 @@ pkgbase = geeqie-lirc
optdepends = fbida: for jpeg rotation
conflicts = geeqie
conflicts = geeqie-git
- source = http://www.geeqie.org/geeqie-1.4.tar.xz
+ source = http://www.geeqie.org/geeqie-1.5.tar.xz
source = geeqie-no-changelog.patch
- sha256sums = 5c583a165573ec37874c278f9dc57e73df356b30e09a9ccac3179dd5d97e3e32
+ sha256sums = 9736c8cbf21cc39d0a9c720934cdd33fe2756dc903c2a12cfc78b8822d2d1bf5
sha256sums = f6eb2725a47fc750d95455d4bbf4be5a0ae45307d3ada571937212a25b2b4301
pkgname = geeqie-lirc
diff --git a/PKGBUILD b/PKGBUILD
index b1a73f3b89be..fadf9cc31a54 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,30 +4,30 @@
pkgname=geeqie-lirc
_upstreampkgname=geeqie
-pkgver=1.4
+pkgver=1.5
pkgrel=1
-pkgdesc="A lightweight image browser and viewer with LIRC support"
+pkgdesc='Lightweight image browser and viewer with LIRC support'
arch=('x86_64')
-url="http://www.geeqie.org/"
+url='http://www.geeqie.org/'
license=('GPL2')
depends=('exiv2' 'gtk2' 'ffmpegthumbnailer' 'lirc')
makedepends=('intltool' 'doxygen' 'gnome-doc-utils' 'python')
optdepends=('librsvg: SVG rendering'
'fbida: for jpeg rotation')
conflicts=('geeqie' 'geeqie-git')
-source=(http://www.geeqie.org/${_upstreampkgname}-${pkgver}.tar.xz geeqie-no-changelog.patch)
-sha256sums=('5c583a165573ec37874c278f9dc57e73df356b30e09a9ccac3179dd5d97e3e32'
+source=("http://www.geeqie.org/${_upstreampkgname}-${pkgver}.tar.xz" 'geeqie-no-changelog.patch')
+sha256sums=('9736c8cbf21cc39d0a9c720934cdd33fe2756dc903c2a12cfc78b8822d2d1bf5'
'f6eb2725a47fc750d95455d4bbf4be5a0ae45307d3ada571937212a25b2b4301')
prepare() {
- cd $_upstreampkgname-$pkgver
+ cd "${srcdir}/${_upstreampkgname}-${pkgver}"
patch -p1 -i ../geeqie-no-changelog.patch # Workaround missing changelog (Fedora)
NOCONFIGURE=1 ./autogen.sh
}
build() {
cd "${srcdir}/${_upstreampkgname}-${pkgver}"
- ./configure --prefix=/usr --enable-lirc
+ ./configure --prefix=/usr --disable-lua --enable-lirc
make
}