summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpezcurrel2017-07-02 13:25:51 +0200
committerpezcurrel2017-07-02 13:25:51 +0200
commit1221ca96a8c47bc743c7b80e33944efe87e0e12c (patch)
treeff6f57606f58d2452b5c1e934634cea4e10c1118
parent940bb0949ad1fb9e86ad4aac3e9aa399c6dbf364 (diff)
downloadaur-1221ca96a8c47bc743c7b80e33944efe87e0e12c.tar.gz
Added patch 'Work around changed c++11 std::string implementation'
-rw-r--r--.SRCINFO9
-rw-r--r--0001-Work-around-changed-c-11-std-string-implementation.patch66
-rw-r--r--PKGBUILD21
3 files changed, 85 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 26c71849835f..281bfab66e4f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Sun Jul 2 11:20:56 UTC 2017
pkgbase = geeqie-lirc
pkgdesc = A lightweight image browser and viewer with remote support (LIRC)
pkgver = 1.3
- pkgrel = 2
+ pkgrel = 3
url = http://www.geeqie.org/
arch = i686
arch = x86_64
@@ -10,17 +12,18 @@ pkgbase = geeqie-lirc
makedepends = doxygen
makedepends = gnome-doc-utils
depends = exiv2
- depends = gtk3
+ depends = gtk2
depends = lcms2
depends = lirc
optdepends = librsvg: SVG rendering
optdepends = fbida: for jpeg rotation
- optdepends = exiv2: for tiff and png rotation
provides = geeqie
conflicts = geeqie
conflicts = geeqie-git
source = http://www.geeqie.org/geeqie-1.3.tar.xz
+ source = 0001-Work-around-changed-c-11-std-string-implementation.patch
sha1sums = f991b44d8587f2f42d5793700c5f6882bed6abf9
+ sha1sums = 45dea6145ab6d74ed69a81a6e5871300f51450eb
pkgname = geeqie-lirc
diff --git a/0001-Work-around-changed-c-11-std-string-implementation.patch b/0001-Work-around-changed-c-11-std-string-implementation.patch
new file mode 100644
index 000000000000..fb4e4a944fde
--- /dev/null
+++ b/0001-Work-around-changed-c-11-std-string-implementation.patch
@@ -0,0 +1,66 @@
+From 0b044d1d685307e5755917e31d56a1a3104cd505 Mon Sep 17 00:00:00 2001
+From: David Kalnischkies <david@kalnischkies.de>
+Date: Fri, 27 May 2016 12:04:40 +0100
+Subject: [PATCH] Work around changed c++11 std::string implementation
+
+Bug was already partly fixed by 96db62d but there was even more
+positions that was unseen by Solomon.
+
+The patch is originally from Debian bug report #800350.
+
+Signed-off-by: Klaus Ethgen <Klaus@Ethgen.de>
+---
+ src/exiv2.cc | 12 +++++++-----
+ 1 file changed, 7 insertions(+), 5 deletions(-)
+
+diff --git a/src/exiv2.cc b/src/exiv2.cc
+index 1dbe1182..49b8e07c 100644
+--- a/src/exiv2.cc
++++ b/src/exiv2.cc
+@@ -25,6 +25,7 @@
+ #include <exiv2/image.hpp>
+ #include <exiv2/exif.hpp>
+ #include <iostream>
++#include <string>
+
+ // EXIV2_TEST_VERSION is defined in Exiv2 0.15 and newer.
+ #ifndef EXIV2_TEST_VERSION
+@@ -1140,8 +1141,9 @@ guchar *exif_get_preview(ExifData *exif, guint *data_len, gint requested_width,
+
+ if (!exif->image()) return NULL;
+
++ std::string const path = exif->image()->io().path();
+ /* given image pathname, first do simple (and fast) file extension test */
+- gboolean is_raw = filter_file_class(exif->image()->io().path().c_str(), FORMAT_CLASS_RAWIMAGE);
++ gboolean is_raw = filter_file_class(path.c_str(), FORMAT_CLASS_RAWIMAGE);
+
+ if (!is_raw && requested_width == 0) return NULL;
+
+@@ -1241,10 +1243,10 @@ extern "C" guchar *exif_get_preview(ExifData *exif, guint *data_len, gint reques
+ if (!exif) return NULL;
+ if (!exif->image()) return NULL;
+
+- const char* path = exif->image()->io().path().c_str();
++ std::string const path = exif->image()->io().path();
+
+ /* given image pathname, first do simple (and fast) file extension test */
+- if (!filter_file_class(path, FORMAT_CLASS_RAWIMAGE)) return NULL;
++ if (!filter_file_class(path.c_str(), FORMAT_CLASS_RAWIMAGE)) return NULL;
+
+ try {
+ struct stat st;
+@@ -1255,9 +1257,9 @@ extern "C" guchar *exif_get_preview(ExifData *exif, guint *data_len, gint reques
+
+ RawFile rf(exif->image()->io());
+ offset = rf.preview_offset();
+- DEBUG_1("%s: offset %lu", path, offset);
++ DEBUG_1("%s: offset %lu", path.c_str(), offset);
+
+- fd = open(path, O_RDONLY);
++ fd = open(path.c_str(), O_RDONLY);
+ if (fd == -1)
+ {
+ return NULL;
+--
+2.13.2
+
diff --git a/PKGBUILD b/PKGBUILD
index e368e7daf71c..d69db09b10bb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,26 +4,31 @@
pkgname=geeqie-lirc
pkgver=1.3
-pkgrel=2
+pkgrel=3
pkgdesc="A lightweight image browser and viewer with remote support (LIRC)"
_cpkgname="geeqie-1.3"
arch=('i686' 'x86_64')
url="http://www.geeqie.org/"
license=('GPL2')
-depends=('exiv2' 'gtk3' 'lcms2' 'lirc')
+depends=('exiv2' 'gtk2' 'lcms2' 'lirc')
makedepends=('intltool' 'doxygen' 'gnome-doc-utils')
optdepends=('librsvg: SVG rendering'
- 'fbida: for jpeg rotation'
- 'exiv2: for tiff and png rotation')
+ 'fbida: for jpeg rotation')
conflicts=('geeqie' 'geeqie-git')
provides=('geeqie')
-source=(http://www.geeqie.org/${_cpkgname}.tar.xz)
-sha1sums=('f991b44d8587f2f42d5793700c5f6882bed6abf9')
+source=("http://www.geeqie.org/${_cpkgname}.tar.xz" '0001-Work-around-changed-c-11-std-string-implementation.patch')
+sha1sums=('f991b44d8587f2f42d5793700c5f6882bed6abf9'
+ '45dea6145ab6d74ed69a81a6e5871300f51450eb')
-build() {
+prepare() {
cd "${srcdir}/${_cpkgname}"
+ patch -Np1 -i ../0001-Work-around-changed-c-11-std-string-implementation.patch
./autogen.sh
- ./configure --prefix=/usr --enable-lirc
+}
+
+build() {
+ cd "${srcdir}/${_cpkgname}"
+ ./configure --prefix=/usr --enable-lirc --disable-gtk3
make
}