summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpezcurrel2018-11-16 13:25:50 +0100
committerpezcurrel2018-11-16 13:25:50 +0100
commit26931b52d9c0c89a37178347d4453fad829faa66 (patch)
treef315a77f0d6deabe98d83e2e9641480dce8eb845
parent1221ca96a8c47bc743c7b80e33944efe87e0e12c (diff)
downloadaur-26931b52d9c0c89a37178347d4453fad829faa66.tar.gz
4.1
-rw-r--r--.SRCINFO21
-rw-r--r--0001-Work-around-changed-c-11-std-string-implementation.patch66
-rw-r--r--PKGBUILD39
-rw-r--r--geeqie-no-changelog.patch14
4 files changed, 42 insertions, 98 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 281bfab66e4f..e81bd958d4bb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,29 +1,26 @@
-# Generated by mksrcinfo v8
-# Sun Jul 2 11:20:56 UTC 2017
pkgbase = geeqie-lirc
- pkgdesc = A lightweight image browser and viewer with remote support (LIRC)
- pkgver = 1.3
- pkgrel = 3
+ pkgdesc = A lightweight image browser and viewer with LIRC support
+ pkgver = 1.4
+ pkgrel = 1
url = http://www.geeqie.org/
- arch = i686
arch = x86_64
license = GPL2
makedepends = intltool
makedepends = doxygen
makedepends = gnome-doc-utils
+ makedepends = python
depends = exiv2
depends = gtk2
- depends = lcms2
+ depends = ffmpegthumbnailer
depends = lirc
optdepends = librsvg: SVG rendering
optdepends = fbida: for jpeg rotation
- provides = geeqie
conflicts = geeqie
conflicts = geeqie-git
- source = http://www.geeqie.org/geeqie-1.3.tar.xz
- source = 0001-Work-around-changed-c-11-std-string-implementation.patch
- sha1sums = f991b44d8587f2f42d5793700c5f6882bed6abf9
- sha1sums = 45dea6145ab6d74ed69a81a6e5871300f51450eb
+ source = http://www.geeqie.org/geeqie-1.4.tar.xz
+ source = geeqie-no-changelog.patch
+ sha256sums = 5c583a165573ec37874c278f9dc57e73df356b30e09a9ccac3179dd5d97e3e32
+ sha256sums = f6eb2725a47fc750d95455d4bbf4be5a0ae45307d3ada571937212a25b2b4301
pkgname = geeqie-lirc
diff --git a/0001-Work-around-changed-c-11-std-string-implementation.patch b/0001-Work-around-changed-c-11-std-string-implementation.patch
deleted file mode 100644
index fb4e4a944fde..000000000000
--- a/0001-Work-around-changed-c-11-std-string-implementation.patch
+++ /dev/null
@@ -1,66 +0,0 @@
-From 0b044d1d685307e5755917e31d56a1a3104cd505 Mon Sep 17 00:00:00 2001
-From: David Kalnischkies <david@kalnischkies.de>
-Date: Fri, 27 May 2016 12:04:40 +0100
-Subject: [PATCH] Work around changed c++11 std::string implementation
-
-Bug was already partly fixed by 96db62d but there was even more
-positions that was unseen by Solomon.
-
-The patch is originally from Debian bug report #800350.
-
-Signed-off-by: Klaus Ethgen <Klaus@Ethgen.de>
----
- src/exiv2.cc | 12 +++++++-----
- 1 file changed, 7 insertions(+), 5 deletions(-)
-
-diff --git a/src/exiv2.cc b/src/exiv2.cc
-index 1dbe1182..49b8e07c 100644
---- a/src/exiv2.cc
-+++ b/src/exiv2.cc
-@@ -25,6 +25,7 @@
- #include <exiv2/image.hpp>
- #include <exiv2/exif.hpp>
- #include <iostream>
-+#include <string>
-
- // EXIV2_TEST_VERSION is defined in Exiv2 0.15 and newer.
- #ifndef EXIV2_TEST_VERSION
-@@ -1140,8 +1141,9 @@ guchar *exif_get_preview(ExifData *exif, guint *data_len, gint requested_width,
-
- if (!exif->image()) return NULL;
-
-+ std::string const path = exif->image()->io().path();
- /* given image pathname, first do simple (and fast) file extension test */
-- gboolean is_raw = filter_file_class(exif->image()->io().path().c_str(), FORMAT_CLASS_RAWIMAGE);
-+ gboolean is_raw = filter_file_class(path.c_str(), FORMAT_CLASS_RAWIMAGE);
-
- if (!is_raw && requested_width == 0) return NULL;
-
-@@ -1241,10 +1243,10 @@ extern "C" guchar *exif_get_preview(ExifData *exif, guint *data_len, gint reques
- if (!exif) return NULL;
- if (!exif->image()) return NULL;
-
-- const char* path = exif->image()->io().path().c_str();
-+ std::string const path = exif->image()->io().path();
-
- /* given image pathname, first do simple (and fast) file extension test */
-- if (!filter_file_class(path, FORMAT_CLASS_RAWIMAGE)) return NULL;
-+ if (!filter_file_class(path.c_str(), FORMAT_CLASS_RAWIMAGE)) return NULL;
-
- try {
- struct stat st;
-@@ -1255,9 +1257,9 @@ extern "C" guchar *exif_get_preview(ExifData *exif, guint *data_len, gint reques
-
- RawFile rf(exif->image()->io());
- offset = rf.preview_offset();
-- DEBUG_1("%s: offset %lu", path, offset);
-+ DEBUG_1("%s: offset %lu", path.c_str(), offset);
-
-- fd = open(path, O_RDONLY);
-+ fd = open(path.c_str(), O_RDONLY);
- if (fd == -1)
- {
- return NULL;
---
-2.13.2
-
diff --git a/PKGBUILD b/PKGBUILD
index d69db09b10bb..b1a73f3b89be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,37 @@
-# Maintainer: pezcurrel <pezcurrel [at] tiscali.it>
-# Maintainer: Eric Bélanger <eric@archlinux.org>
+# Maintainer: pezcurrel <pezcurrel@tiscali.it>
+# Contributor: Eric Bélanger <eric@archlinux.org>
# Contributor: Lukas Jirkovsky <l.jirkovsky@gmail.com>
pkgname=geeqie-lirc
-pkgver=1.3
-pkgrel=3
-pkgdesc="A lightweight image browser and viewer with remote support (LIRC)"
-_cpkgname="geeqie-1.3"
-arch=('i686' 'x86_64')
+_upstreampkgname=geeqie
+pkgver=1.4
+pkgrel=1
+pkgdesc="A lightweight image browser and viewer with LIRC support"
+arch=('x86_64')
url="http://www.geeqie.org/"
license=('GPL2')
-depends=('exiv2' 'gtk2' 'lcms2' 'lirc')
-makedepends=('intltool' 'doxygen' 'gnome-doc-utils')
+depends=('exiv2' 'gtk2' 'ffmpegthumbnailer' 'lirc')
+makedepends=('intltool' 'doxygen' 'gnome-doc-utils' 'python')
optdepends=('librsvg: SVG rendering'
- 'fbida: for jpeg rotation')
+ 'fbida: for jpeg rotation')
conflicts=('geeqie' 'geeqie-git')
-provides=('geeqie')
-source=("http://www.geeqie.org/${_cpkgname}.tar.xz" '0001-Work-around-changed-c-11-std-string-implementation.patch')
-sha1sums=('f991b44d8587f2f42d5793700c5f6882bed6abf9'
- '45dea6145ab6d74ed69a81a6e5871300f51450eb')
+source=(http://www.geeqie.org/${_upstreampkgname}-${pkgver}.tar.xz geeqie-no-changelog.patch)
+sha256sums=('5c583a165573ec37874c278f9dc57e73df356b30e09a9ccac3179dd5d97e3e32'
+ 'f6eb2725a47fc750d95455d4bbf4be5a0ae45307d3ada571937212a25b2b4301')
prepare() {
- cd "${srcdir}/${_cpkgname}"
- patch -Np1 -i ../0001-Work-around-changed-c-11-std-string-implementation.patch
- ./autogen.sh
+ cd $_upstreampkgname-$pkgver
+ patch -p1 -i ../geeqie-no-changelog.patch # Workaround missing changelog (Fedora)
+ NOCONFIGURE=1 ./autogen.sh
}
build() {
- cd "${srcdir}/${_cpkgname}"
- ./configure --prefix=/usr --enable-lirc --disable-gtk3
+ cd "${srcdir}/${_upstreampkgname}-${pkgver}"
+ ./configure --prefix=/usr --enable-lirc
make
}
package(){
- cd "${srcdir}/${_cpkgname}"
+ cd "${srcdir}/${_upstreampkgname}-${pkgver}"
make DESTDIR="${pkgdir}" install
}
diff --git a/geeqie-no-changelog.patch b/geeqie-no-changelog.patch
new file mode 100644
index 000000000000..1b8833b135f3
--- /dev/null
+++ b/geeqie-no-changelog.patch
@@ -0,0 +1,14 @@
+--- geeqie-1.4.orig/Makefile.am 2017-12-31 07:31:21.000000000 -0500
++++ geeqie-1.4/Makefile.am 2018-01-01 15:05:58.742068166 -0500
+@@ -10,9 +10,9 @@
+ readmedir = @readmedir@
+
+ if HAVE_MARKDOWN
+-readme_DATA = README.md COPYING ChangeLog TODO README.lirc AUTHORS README.html ChangeLog.html
++readme_DATA = README.md COPYING TODO README.lirc AUTHORS README.html
+ else
+-readme_DATA = README.md COPYING ChangeLog TODO README.lirc AUTHORS ChangeLog.html
++readme_DATA = README.md COPYING TODO README.lirc AUTHORS
+ endif
+
+ desktopdir = $(datadir)/applications