summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpezcurrel2015-12-13 20:17:06 +0100
committerpezcurrel2015-12-13 20:17:06 +0100
commit4aa964fdcee1adad16b6d5e64dbf95de7dde9f6f (patch)
treef7d95aca323420ab219e62aec85ed3763bb7c7be
parent7961890e485726406ad13dbfaccc833667001d18 (diff)
downloadaur-4aa964fdcee1adad16b6d5e64dbf95de7dde9f6f.tar.gz
Update to 1.2.2-1
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD44
-rw-r--r--fix-fullscreen.patch107
3 files changed, 147 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6b9c503ec01f..612dc49e5568 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,31 +1,33 @@
# Generated by mksrcinfo v8
-# Sun Dec 13 10:19:38 UTC 2015
+# Sun Dec 13 19:15:36 UTC 2015
pkgbase = geeqie-lirc
- pkgdesc = A lightweight image browser and viewer (fork of GQview) - with LIRC enabled
- pkgver = 1.1
- pkgrel = 3
- url = http://geeqie.sourceforge.net/
+ pkgdesc = A lightweight image browser and viewer with remote (LIRC) support
+ pkgver = 1.2.2
+ pkgrel = 1
+ url = http://www.geeqie.org/
install = geeqie.install
arch = i686
arch = x86_64
- license = GPL3
- makedepends = git
+ license = GPL2
makedepends = intltool
makedepends = doxygen
makedepends = gnome-doc-utils
+ makedepends = git
depends = exiv2
depends = gtk2
depends = lcms
+ depends = lirc
depends = desktop-file-utils
- depends = lirc-utils
optdepends = librsvg: SVG rendering
+ optdepends = fbida: for jpeg rotation
+ optdepends = exiv2: for tiff and png rotation
provides = geeqie
conflicts = geeqie
conflicts = geeqie-git
- replaces = gqview
- replaces = gqview-devel
- source = http://downloads.sourceforge.net/project/geeqie/geeqie/geeqie-1.1/geeqie-1.1.tar.gz
- md5sums = e63351988625c84b0fd80bc4eefd923b
+ source = http://www.geeqie.org/geeqie-1.2.2.tar.xz
+ source = fix-fullscreen.patch
+ sha1sums = 9dd094707d7bf7389eb62a218ff7bc86339fc995
+ sha1sums = dab15bbda9b329f663276b25bf1989b410596644
pkgname = geeqie-lirc
diff --git a/PKGBUILD b/PKGBUILD
index 20c7e933d452..0c798346572e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,41 @@
# Maintainer: pezcurrel <pezcurrel [at] tiscali.it>
# Maintainer: <kontakt.zuf [at] gmail.com>
# Maintainer: Eric BĂ©langer <eric [at] archlinux.org>
-# Maintainer: Lukas Jirkovsky <l.jirkovsky [at] gmail.com>
+# Contributor: Lukas Jirkovsky <l.jirkovsky [at] gmail.com>
pkgname=geeqie-lirc
-pkgver=1.1
-pkgrel=3
-pkgdesc="A lightweight image browser and viewer (fork of GQview) - with LIRC enabled"
+_pkgname=geeqie
+pkgver=1.2.2
+pkgrel=1
+pkgdesc="A lightweight image browser and viewer with remote (LIRC) support"
arch=('i686' 'x86_64')
-url="http://geeqie.sourceforge.net/"
-license=('GPL3')
-depends=('exiv2' 'gtk2' 'lcms' 'desktop-file-utils' 'lirc-utils')
-makedepends=('git' 'intltool' 'doxygen' 'gnome-doc-utils')
-optdepends=('librsvg: SVG rendering')
-replaces=('gqview' 'gqview-devel')
+url="http://www.geeqie.org/"
+license=('GPL2')
+depends=('exiv2' 'gtk2' 'lcms' 'lirc' 'desktop-file-utils')
+makedepends=('intltool' 'doxygen' 'gnome-doc-utils' 'git')
+optdepends=('librsvg: SVG rendering'
+ 'fbida: for jpeg rotation'
+ 'exiv2: for tiff and png rotation')
conflicts=('geeqie' 'geeqie-git')
provides=('geeqie')
install=geeqie.install
-source=( "http://downloads.sourceforge.net/project/geeqie/geeqie/geeqie-1.1/geeqie-1.1.tar.gz" )
-md5sums=( 'e63351988625c84b0fd80bc4eefd923b' )
+source=(http://www.geeqie.org/${_pkgname}-${pkgver}.tar.xz
+ fix-fullscreen.patch)
+sha1sums=('9dd094707d7bf7389eb62a218ff7bc86339fc995'
+ 'dab15bbda9b329f663276b25bf1989b410596644')
+
+prepare() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ patch -p1 -i ../fix-fullscreen.patch
+}
build() {
- cd "${srcdir}/geeqie-1.1"
- CPPFLAGS="-D_FILE_OFFSET_BITS=64" ./configure --prefix=/usr --enable-lirc
- make
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ ./configure --prefix=/usr --enable-lirc
+ make
}
package(){
- cd "$srcdir/geeqie-1.1"
- install -d -m755 "${pkgdir}/usr/share/doc/geeqie-1.1/html"
- make DESTDIR="${pkgdir}" install
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
}
diff --git a/fix-fullscreen.patch b/fix-fullscreen.patch
new file mode 100644
index 000000000000..714db880be82
--- /dev/null
+++ b/fix-fullscreen.patch
@@ -0,0 +1,107 @@
+diff -Naur old/src/fullscreen.c new/src/fullscreen.c
+--- old/src/fullscreen.c 2015-08-16 16:37:58.132952447 +0900
++++ new/src/fullscreen.c 2015-08-16 16:43:30.031882508 +0900
+@@ -210,10 +210,6 @@
+ void (*stop_func)(FullScreenData *, gpointer), gpointer stop_data)
+ {
+ FullScreenData *fs;
+- GdkScreen *screen;
+- gint x, y;
+- gint w, h;
+- GdkGeometry geometry;
+ GdkWindow *gdkwin;
+
+ if (!window || !imd) return NULL;
+@@ -229,14 +225,9 @@
+ fs->stop_data = stop_data;
+
+ DEBUG_1("full screen requests screen %d", options->fullscreen.screen);
+- fullscreen_prefs_get_geometry(options->fullscreen.screen, window, &x, &y, &w, &h,
+- &screen, &fs->same_region);
+
+ fs->window = window_new(GTK_WINDOW_TOPLEVEL, "fullscreen", NULL, NULL, _("Full screen"));
+
+- /* this requests no decorations, if you still have them complain to the window manager author(s) */
+- gtk_window_set_decorated(GTK_WINDOW(fs->window), FALSE);
+-
+ if (options->fullscreen.screen < 0)
+ {
+ /* If we want control of the window size and position this is not what we want.
+@@ -246,9 +237,42 @@
+ }
+ else
+ {
+- gtk_window_set_screen(GTK_WINDOW(fs->window), screen);
++ GdkScreen *screen;
++ gint x, y;
++ gint w, h;
++ GdkGeometry geometry;
++
++ fullscreen_prefs_get_geometry(options->fullscreen.screen, window, &x, &y, &w, &h,
++ &screen, &fs->same_region);
++
+ if (options->fullscreen.above)
+ gtk_window_set_keep_above(GTK_WINDOW(fs->window), TRUE);
++
++ gtk_window_set_screen(GTK_WINDOW(fs->window), screen);
++ gtk_window_set_decorated(GTK_WINDOW(fs->window), FALSE);
++ gtk_window_set_resizable(GTK_WINDOW(fs->window), FALSE);
++ gtk_container_set_border_width(GTK_CONTAINER(fs->window), 0);
++
++ geometry.min_width = w;
++ geometry.min_height = h;
++ geometry.max_width = w;
++ geometry.max_height = h;
++ geometry.base_width = w;
++ geometry.base_height = h;
++ geometry.win_gravity = GDK_GRAVITY_STATIC;
++
++ gtk_window_set_geometry_hints(GTK_WINDOW(fs->window), fs->window, &geometry,
++ GDK_HINT_MIN_SIZE | GDK_HINT_MAX_SIZE | GDK_HINT_BASE_SIZE |
++ GDK_HINT_WIN_GRAVITY |
++ GDK_HINT_USER_POS);
++
++ gtk_window_set_default_size(GTK_WINDOW(fs->window), w, h);
++ gtk_window_move(GTK_WINDOW(fs->window), x, y);
++
++ gtk_widget_realize(fs->window);
++ gdkwin = gtk_widget_get_window(fs->window);
++ if (gdkwin != NULL)
++ gdk_window_set_override_redirect(gdkwin, TRUE);
+ }
+
+ gtk_window_set_resizable(GTK_WINDOW(fs->window), FALSE);
+@@ -256,33 +280,6 @@
+ g_signal_connect(G_OBJECT(fs->window), "delete_event",
+ G_CALLBACK(fullscreen_delete_cb), fs);
+
+- geometry.min_width = w;
+- geometry.min_height = h;
+- geometry.max_width = w;
+- geometry.max_height = h;
+- geometry.base_width = w;
+- geometry.base_height = h;
+- geometry.win_gravity = GDK_GRAVITY_STATIC;
+- /* By setting USER_POS and USER_SIZE, most window managers will
+- * not request positioning of the full screen window (for example twm).
+- *
+- * In addition, setting gravity to STATIC will result in the
+- * decorations of twm to not effect the requested window position,
+- * the decorations will simply be off screen, except in multi monitor setups :-/
+- */
+- gtk_window_set_geometry_hints(GTK_WINDOW(fs->window), fs->window, &geometry,
+- GDK_HINT_MIN_SIZE | GDK_HINT_MAX_SIZE | GDK_HINT_BASE_SIZE |
+- GDK_HINT_WIN_GRAVITY |
+- GDK_HINT_USER_POS);
+-
+- gtk_window_set_default_size(GTK_WINDOW(fs->window), w, h);
+- gtk_window_move(GTK_WINDOW(fs->window), x, y);
+-
+- gtk_widget_realize(fs->window);
+- gdkwin = gtk_widget_get_window(fs->window);
+- if (gdkwin != NULL)
+- gdk_window_set_override_redirect(gdkwin, TRUE);
+-
+ fs->imd = image_new(FALSE);
+
+ gtk_container_add(GTK_CONTAINER(fs->window), fs->imd->widget);