summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2019-08-19 15:16:56 +0200
committerbartus2019-08-19 15:19:50 +0200
commit2082a2d715ab373c06e9ecbfab3e49ce251c977d (patch)
tree1d463397762e05b8a2c61b45a42eae2785928db6
parent2da17e3d3d126b441e81fe171628d5efbe504bc8 (diff)
downloadaur-2082a2d715ab373c06e9ecbfab3e49ce251c977d.tar.gz
Switch to meson, as autotools build system was removed
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD48
2 files changed, 24 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 95d7330d5c1a..75c959381066 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
-pkgbase = gegl-git
+pkgbase = gegl-qfix-git
pkgdesc = Graph based image processing framework
- pkgver = 0.4.9.r8934.cf7eacb75
+ pkgver = 0.4.17.r29.2da17e3
pkgrel = 1
url = http://www.gegl.org
arch = i686
@@ -8,6 +8,7 @@ pkgbase = gegl-git
license = GPL3
license = LGPL3
makedepends = git
+ makedepends = meson
makedepends = intltool
makedepends = python2
makedepends = ruby
@@ -20,7 +21,7 @@ pkgbase = gegl-git
makedepends = libtiff
makedepends = suitesparse
makedepends = gobject-introspection
- depends = babl>=0.1.54
+ depends = babl>=0.1.71
depends = libspiro
depends = json-glib
optdepends = openexr: for using the openexr plugin
@@ -31,11 +32,11 @@ pkgbase = gegl-git
optdepends = libraw: raw plugin
optdepends = suitesparse: matting-levin plugin
optdepends = lua: lua plugin
- provides = gegl=0.4.9.r8934.cf7eacb75
+ provides = gegl=0.4.17.r29.2da17e3
conflicts = gegl
options = !libtool
source = git+https://gitlab.gnome.org/GNOME/gegl.git
sha512sums = SKIP
-pkgname = gegl-git
+pkgname = gegl-qfix-git
diff --git a/PKGBUILD b/PKGBUILD
index 249a6910fa8a..8f1c3d1c9351 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,16 +4,16 @@
# Contributor: Alessio Biancalana <dottorblaster@gmail.com>
# Contributor: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
-pkgname=gegl-git
-_pkgname=${pkgname%-git}
-pkgver=0.4.9.r8934.cf7eacb75
+pkgname=gegl-qfix-git
+_pkgname=${pkgname%-qfix-git}
+pkgver=0.4.17.r29.2da17e3
pkgrel=1
pkgdesc="Graph based image processing framework"
arch=('i686' 'x86_64')
url="http://www.gegl.org"
license=('GPL3' 'LGPL3')
-depends=('babl>=0.1.68' 'libspiro' 'json-glib')
-makedepends=('git' 'intltool' 'python2' 'ruby' 'lua'
+depends=('babl>=0.1.71' 'libspiro' 'json-glib')
+makedepends=('git' 'meson' 'intltool' 'python2' 'ruby' 'lua'
'libraw' 'openexr' 'ffmpeg' 'librsvg' 'jasper'
'libtiff' 'suitesparse' 'gobject-introspection')
optdepends=('openexr: for using the openexr plugin'
@@ -31,40 +31,28 @@ source=('git+https://gitlab.gnome.org/GNOME/gegl.git')
sha512sums=('SKIP')
pkgver() {
- cd $_pkgname
-
- printf "%s.r%s.%s" \
- $(cat configure.ac | grep '^m4_define(\[gegl_.*_version\], \[[0-9]*\])' | tr -d '\n' | sed -e 's|^m4_define(\[gegl_major_version\], \[||' -e 's|\])m4_define(\[gegl_minor_version\], \[|.|' -e 's|\])m4_define(\[gegl_micro_version\], \[|.|' -e 's|\])|\n|') \
- $(git rev-list --count HEAD) \
- $(git rev-parse --short HEAD)
+ printf "%d.%d.%d.r%s.%s" \
+ $(grep -Po '^#define GEGL_MAJOR_VERSION \K[0-9]*$' build/config.h) \
+ $(grep -Po '^#define GEGL_MINOR_VERSION \K[0-9]*$' build/config.h) \
+ $(grep -Po '^#define GEGL_MICRO_VERSION \K[0-9]*$' build/config.h) \
+ $(git rev-list --count HEAD) \
+ $(git rev-parse --short HEAD)
}
prepare() {
- cd $_pkgname
-
- autoreconf -if
+ mkdir "${srcdir}/build" -p
- ./configure \
- --prefix=/usr \
- --with-sdl \
- --with-openexr \
- --with-librsvg \
- --with-libavformat \
- --with-jasper \
- --disable-docs \
- --enable-workshop \
- --enable-introspection=yes
+ meson "${srcdir}/${_pkgname}" \
+ "${srcdir}/build" \
+ --prefix=/usr \
+ -Dworkshop=true
}
build() {
- cd $_pkgname
-
- make
+ ninja -C "${srcdir}/build"
}
package() {
- cd $_pkgname
-
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" ninja -C "${srcdir}/build" install
}