summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2019-08-21 23:59:36 +0200
committerbartus2019-08-21 23:59:36 +0200
commit71e37846a684fd8425a90f65d09add2f450f2688 (patch)
tree68c097a8279b22a3d5cef87da3c2ff8bd3f6472a
parent9ec7d6b93216961f23530caa595e9e8698f7f52d (diff)
downloadaur-71e37846a684fd8425a90f65d09add2f450f2688.tar.gz
Fix pkgver()
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 75c959381066..ef55c77d3f28 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gegl-qfix-git
pkgdesc = Graph based image processing framework
- pkgver = 0.4.17.r29.2da17e3
+ pkgver = 0.4.17.r9768.e1aa95ac1
pkgrel = 1
url = http://www.gegl.org
arch = i686
@@ -32,7 +32,7 @@ pkgbase = gegl-qfix-git
optdepends = libraw: raw plugin
optdepends = suitesparse: matting-levin plugin
optdepends = lua: lua plugin
- provides = gegl=0.4.17.r29.2da17e3
+ provides = gegl=0.4.17.r9768.e1aa95ac1
conflicts = gegl
options = !libtool
source = git+https://gitlab.gnome.org/GNOME/gegl.git
diff --git a/PKGBUILD b/PKGBUILD
index 8f1c3d1c9351..8449befd1b75 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=gegl-qfix-git
_pkgname=${pkgname%-qfix-git}
-pkgver=0.4.17.r29.2da17e3
+pkgver=0.4.17.r9768.e1aa95ac1
pkgrel=1
pkgdesc="Graph based image processing framework"
arch=('i686' 'x86_64')
@@ -31,10 +31,11 @@ source=('git+https://gitlab.gnome.org/GNOME/gegl.git')
sha512sums=('SKIP')
pkgver() {
+ cd ${srcdir}/${_pkgname}
printf "%d.%d.%d.r%s.%s" \
- $(grep -Po '^#define GEGL_MAJOR_VERSION \K[0-9]*$' build/config.h) \
- $(grep -Po '^#define GEGL_MINOR_VERSION \K[0-9]*$' build/config.h) \
- $(grep -Po '^#define GEGL_MICRO_VERSION \K[0-9]*$' build/config.h) \
+ $(grep -Po '^#define GEGL_MAJOR_VERSION \K[0-9]*$' ${srcdir}/build/config.h) \
+ $(grep -Po '^#define GEGL_MINOR_VERSION \K[0-9]*$' ${srcdir}/build/config.h) \
+ $(grep -Po '^#define GEGL_MICRO_VERSION \K[0-9]*$' ${srcdir}/build/config.h) \
$(git rev-list --count HEAD) \
$(git rev-parse --short HEAD)
}