summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMalte Bublitz2015-06-14 21:06:26 +0200
committerMalte Bublitz2015-06-14 21:07:28 +0200
commita56708f6a86a1d6348b811b1243d8c6c8af69c32 (patch)
tree6441d7e515a25a27f2e69f3b52edbb20df8811a2
downloadaur-a56708f6a86a1d6348b811b1243d8c6c8af69c32.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD28
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2b6dda8cef71
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = geheim
+ pkgdesc = Simple password manager which tries to follow the Unix principles, written in Bash and using Tar and GnuPG to store passwords.
+ pkgver = 0.1.1
+ pkgrel = 2
+ url = http://malte-bublitz.de/geheim
+ arch = any
+ license = BSD
+ makedepends = make
+ depends = gnupg
+ depends = tar
+ source = geheim-0.1.1.tar.gz::https://github.com/malte70/geheim/archive/0.1.1.tar.gz
+ sha256sums = e3153bcd7ccbeb7ed37446073f6a61c3ecc2afd7ddbb4950a6b45ee441a5dbcc
+
+pkgname = geheim
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f5f55c8fb653
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Malte Bublitz <malte70+aur[at]mcbx[dot]de>
+
+pkgname=geheim
+pkgver=0.1.1
+pkgrel=2
+pkgdesc="Simple password manager which tries to follow the Unix principles, written in Bash and using Tar and GnuPG to store passwords."
+arch=(any)
+url="http://malte-bublitz.de/geheim"
+license=("BSD")
+depends=("gnupg" "tar")
+makedepends=("make")
+source=("$pkgname-$pkgver.tar.gz::https://github.com/malte70/$pkgname/archive/$pkgver.tar.gz")
+sha256sums=('e3153bcd7ccbeb7ed37446073f6a61c3ecc2afd7ddbb4950a6b45ee441a5dbcc')
+
+check() {
+ cd "${srcdir}/$pkgname-${pkgver}"
+ make -B test
+}
+
+build() {
+ true
+}
+
+package() {
+ cd "${srcdir}/$pkgname-${pkgver}"
+ make DEST=${pkgdir}/usr install
+}
+# vim:set ts=2 sw=2 noet: