summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorniQo2016-05-09 21:30:33 +0200
committerniQo2016-05-09 21:30:33 +0200
commit318a445f2b218b50e41d07439c03f80c1e75a3b9 (patch)
tree6c1a6fee86f00a0bb5a084c79873ec4249f27766
parentcdc6062decd7a6ddc076f3dd12fcec9fadb08721 (diff)
downloadaur-318a445f2b218b50e41d07439c03f80c1e75a3b9.tar.gz
upgrade to v2.2.17
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD15
2 files changed, 10 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c63cff722f4c..5664f514dd1d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = geis
pkgdesc = Implementation of the GEIS (Gesture Engine Interface and Support) interface.
- pkgver = 2.2.16
- pkgrel = 2
+ pkgver = 2.2.17
+ pkgrel = 1
url = https://launchpad.net/geis
arch = i686
arch = x86_64
@@ -16,10 +16,8 @@ pkgbase = geis
replaces = utouch-geis
options = !emptydirs
options = !libtool
- source = http://launchpad.net/geis/trunk/2.2.16/+download/geis-2.2.16.tar.gz
- source = http://bazaar.launchpad.net/~ken-vandine/geis/lp1428314/diff/328?context=3
- md5sums = 550c78b5185b835b80dba14537c2c83d
- md5sums = 2ff7e280b846f363691c3749930bd79d
+ source = http://launchpad.net/geis/trunk/2.2.17/+download/geis-2.2.17.tar.xz
+ md5sums = 2ff9d76a3ea5794516bb02c9d1924faf
pkgname = geis
diff --git a/PKGBUILD b/PKGBUILD
index 66352bedfc6b..5a5db1ab0a34 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: Xiao-Long Chen <chenxiaolong@cxl.epac.to>
pkgname=geis
-pkgver=2.2.16
-pkgrel=2
+pkgver=2.2.17
+pkgrel=1
pkgdesc="Implementation of the GEIS (Gesture Engine Interface and Support) interface."
arch=('i686' 'x86_64')
url="https://launchpad.net/geis"
@@ -14,27 +14,24 @@ provides=('utouch-geis')
conflicts=('utouch-geis')
replaces=('utouch-geis')
options=('!emptydirs' '!libtool')
-source=("http://launchpad.net/${pkgname}/trunk/${pkgver}/+download/${pkgname}-${pkgver}.tar.gz" \
- "http://bazaar.launchpad.net/~ken-vandine/geis/lp1428314/diff/328?context=3")
-md5sums=('550c78b5185b835b80dba14537c2c83d'
- '2ff7e280b846f363691c3749930bd79d')
+source=("http://launchpad.net/${pkgname}/trunk/${pkgver}/+download/${pkgname}-${pkgver}.tar.xz")
+md5sums=('2ff9d76a3ea5794516bb02c9d1924faf')
+
prepare() {
cd "$pkgname-$pkgver"
- patch -p0 -i '../328?context=3'
}
build() {
cd "$pkgname-$pkgver"
## add -Wno-format in CFLAGS see FS#34658
- CFLAGS="$CFLAGS -Wno-format" ./configure --prefix=/usr --disable-static
+ CFLAGS="$CFLAGS -Wno-format -Wno-misleading-indentation" ./configure --prefix=/usr --disable-static
make
}
package() {
cd "$pkgname-$pkgver"
-
make DESTDIR="${pkgdir}/" install
}