summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorniQo2015-06-16 12:51:18 +0200
committerniQo2015-06-16 12:51:18 +0200
commit9e92d27fe94c9bdc22a0895be4c17848a9befba3 (patch)
tree1a391c418b6a6616418a0f95f2c2c218747d9df6
downloadaur-9e92d27fe94c9bdc22a0895be4c17848a9befba3.tar.gz
Initial import
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD40
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dcc5aa5b3ed6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = geis
+ pkgdesc = Implementation of the GEIS (Gesture Engine Interface and Support) interface.
+ pkgver = 2.2.16
+ pkgrel = 1
+ url = https://launchpad.net/geis
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = LGPL
+ makedepends = xorg-server-devel
+ depends = grail
+ depends = dbus
+ depends = python-gobject
+ provides = utouch-geis
+ conflicts = utouch-geis
+ replaces = utouch-geis
+ options = !emptydirs
+ options = !libtool
+ source = http://launchpad.net/geis/trunk/2.2.16/+download/geis-2.2.16.tar.gz
+ source = http://bazaar.launchpad.net/~ken-vandine/geis/lp1428314/diff/328?context=3
+ md5sums = 550c78b5185b835b80dba14537c2c83d
+ md5sums = 2ff7e280b846f363691c3749930bd79d
+
+pkgname = geis
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c09e0388bc22
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Nicolas QuiƩnot <niQo @ AUR >
+# Contributor: Xiao-Long Chen <chenxiaolong@cxl.epac.to>
+
+pkgname=geis
+pkgver=2.2.16
+pkgrel=1
+pkgdesc="Implementation of the GEIS (Gesture Engine Interface and Support) interface."
+arch=('i686' 'x86_64')
+url="https://launchpad.net/geis"
+license=('GPL' 'LGPL')
+depends=('grail' 'dbus' 'python-gobject')
+makedepends=('xorg-server-devel')
+provides=('utouch-geis')
+conflicts=('utouch-geis')
+replaces=('utouch-geis')
+options=('!emptydirs' '!libtool')
+source=("http://launchpad.net/${pkgname}/trunk/${pkgver}/+download/${pkgname}-${pkgver}.tar.gz" \
+ "http://bazaar.launchpad.net/~ken-vandine/geis/lp1428314/diff/328?context=3")
+md5sums=('550c78b5185b835b80dba14537c2c83d'
+ '2ff7e280b846f363691c3749930bd79d')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ patch -p0 -i '../328?context=3'
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ ## add -Wno-format in CFLAGS see FS#34658
+ CFLAGS="$CFLAGS -Wno-format" ./configure --prefix=/usr --disable-static
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ make DESTDIR="${pkgdir}/" install
+}
+