summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgohny2023-12-14 06:11:39 +0100
committergohny2023-12-14 06:11:39 +0100
commit5db45098e441aa6cd71bd0b6fc6d066a1c90b1c1 (patch)
tree838d2c72e8f120767bbc93c87d8e2d0226494392
downloadaur-5db45098e441aa6cd71bd0b6fc6d066a1c90b1c1.tar.gz
Hello World!
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD18
2 files changed, 31 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..308009a0e9eb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = gem
+ pkgdesc = Command-line tool written in bash to backup and manage Gnome extensions and their configs
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/gohny/gem
+ arch = x86_64
+ license = GPL3
+ makedepends = make
+ depends = glib2
+ source = gem-0.1.0.tar.gz::https://github.com/gohny/gem/archive/refs/tags/0.1.0.tar.gz
+ sha256sums = 67c15c5ba7850ee7788c195d9a62a2e078842d8174224bfc9177bb7019938d74
+
+pkgname = gem
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7f4eee07e478
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Gohny <gohny277@gmail.com>
+pkgname='gem'
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Command-line tool written in bash to backup and manage Gnome extensions and their configs"
+arch=('x86_64')
+url="https://github.com/gohny/gem"
+license=('GPL3')
+depends=('glib2')
+makedepends=('make')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/refs/tags/$pkgver.tar.gz")
+sha256sums=('67c15c5ba7850ee7788c195d9a62a2e078842d8174224bfc9177bb7019938d74')
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 ./gem "$pkgdir/usr/bin/gem"
+ echo $pkgdir
+}