summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorvn1582017-09-19 22:45:44 +0200
committervn1582017-09-19 22:45:44 +0200
commitfd860a5077c3b1826427b7a6a7ff2dc21562e073 (patch)
tree6daa3c01023bd345f977fa8d19d4b0b59887f29e
downloadaur-fd860a5077c3b1826427b7a6a7ff2dc21562e073.tar.gz
first commit, all looks OK
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD37
-rwxr-xr-xgemcraft02
-rw-r--r--gemcraft0.desktop11
4 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..667e1b56fd59
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = gemcraft0
+ pkgdesc = Unleash your magic power and fight. The Gem of Eternity awaits you...
+ pkgver = 1.20
+ pkgrel = 1
+ url = http://armorgames.com/play/3527/gemcraft-chapter-0
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = imagemagick
+ depends = flashplayer-standalone
+ options = !strip
+ source = gemcraft0.swf::http://cache.armorgames.com/files/games/gemcraft-chapter-0-3527.swf
+ source = http://gameinabottle.com/favicon.ico
+ source = gemcraft0
+ source = gemcraft0.desktop
+ md5sums = ce3d8f0d5d28766542abf58b37c0bbaf
+ md5sums = 14f045b8d2a7d75de7cdb27dd4e9d6cd
+ md5sums = c0f0ccee19a63336245269df56a44989
+ md5sums = d1eec9e315dcd99c1126b11f8fc698ab
+ sha256sums = 6d51944b86a8d6b98a36667e204a2723c96adbf7914d9634cbac643f922790af
+ sha256sums = 7d6f3457786f44758f1e2e9fcd1aa0837d0392cf2358fc966d93a666f81b7d03
+ sha256sums = df290b1fed66a7b53ee02ce3630f0e83c1503959951c5425f6cfd66f86b21671
+ sha256sums = c1dd509659573f9e9d0427d6a8f675e67df0307c4820dbf0005cf237c95ebf85
+
+pkgname = gemcraft0
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..28edd3349e53
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: vn158 <vn158 at seznam dot cz>
+
+pkgname=gemcraft0
+pkgver=1.20
+pkgrel=1
+pkgdesc="Unleash your magic power and fight. The Gem of Eternity awaits you..."
+arch=('i686' 'x86_64')
+url="http://armorgames.com/play/3527/gemcraft-chapter-0"
+license=('custom')
+depends=("flashplayer-standalone")
+makedepends=('imagemagick')
+source=(${pkgname}.swf::http://cache.armorgames.com/files/games/gemcraft-chapter-0-3527.swf http://gameinabottle.com/favicon.ico ${pkgname} ${pkgname}.desktop)
+
+md5sums=('ce3d8f0d5d28766542abf58b37c0bbaf'
+ '14f045b8d2a7d75de7cdb27dd4e9d6cd'
+ 'c0f0ccee19a63336245269df56a44989'
+ 'd1eec9e315dcd99c1126b11f8fc698ab')
+sha256sums=('6d51944b86a8d6b98a36667e204a2723c96adbf7914d9634cbac643f922790af'
+ '7d6f3457786f44758f1e2e9fcd1aa0837d0392cf2358fc966d93a666f81b7d03'
+ 'df290b1fed66a7b53ee02ce3630f0e83c1503959951c5425f6cfd66f86b21671'
+ 'c1dd509659573f9e9d0427d6a8f675e67df0307c4820dbf0005cf237c95ebf85')
+
+options=(!strip)
+
+build () {
+ convert favicon.ico ${pkgname}.png
+}
+
+package() {
+ #if path contains d8krhj4kasdu3 extra features are allowed, it doesn't work with 1.21
+ install -d "${pkgdir}"/usr/{bin,share/${pkgname}/d8krhj4kasdu3}
+ install -d "${pkgdir}"/usr/share/applications
+ install -m644 ${pkgname}.png "${pkgdir}"/usr/share/${pkgname}
+ install -m644 ${pkgname}.swf "${pkgdir}"/usr/share/${pkgname}/d8krhj4kasdu3
+ install -m644 ${pkgname}.desktop "${pkgdir}"/usr/share/applications
+ install -m755 ${pkgname} "${pkgdir}"/usr/bin
+}
diff --git a/gemcraft0 b/gemcraft0
new file mode 100755
index 000000000000..404df075dcb3
--- /dev/null
+++ b/gemcraft0
@@ -0,0 +1,2 @@
+#!/bin/bash
+flashplayer /usr/share/gemcraft0/d8krhj4kasdu3/gemcraft0.swf
diff --git a/gemcraft0.desktop b/gemcraft0.desktop
new file mode 100644
index 000000000000..52411650cabf
--- /dev/null
+++ b/gemcraft0.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=GemCraft chapter 0: Gem of Eternity
+GenericName=GemCraft chapter 0: Gem of Eternity
+Comment=
+Exec=/usr/bin/gemcraft0
+Icon=/usr/share/gemcraft0/gemcraft0.png
+StartupNotify=true
+Terminal=false
+Type=Application
+Categories=Application;Game