summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorvn1582017-09-19 19:35:50 +0200
committervn1582017-09-19 19:35:50 +0200
commit859bf19f6cb5b73b8c5ac9ff79a022127ea3266b (patch)
treec090f000a61e7c1c85fc6fc78293a08f629ac77a
downloadaur-gemcraft1.tar.gz
first commit, all looks OK
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD39
-rwxr-xr-xgemcraft12
-rw-r--r--gemcraft1.desktop11
4 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..310aea7b9c02
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = gemcraft1
+ pkgdesc = Create and combine magic gems, put them into your towers and banish the monsters back to hell!
+ pkgver = 1.111A
+ pkgrel = 1
+ url = http://armorgames.com/play/1716/gemcraft
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = imagemagick
+ depends = flashplayer-standalone
+ options = !strip
+ source = http://gameinabottle.com/games/gemcraft1.swf
+ source = http://gameinabottle.com/favicon.ico
+ source = gemcraft1
+ source = gemcraft1.desktop
+ md5sums = 4ae0f6369520686ae1e8433ebe564170
+ md5sums = 14f045b8d2a7d75de7cdb27dd4e9d6cd
+ md5sums = cade4ab4245725f2148b72326e550d7a
+ md5sums = 5c2f2f548be56b4b97d4eda201a2f833
+ sha256sums = b7773ff1118aae4c36352e9d67e9430e36545b4255c5a3105ecfeef4957369ec
+ sha256sums = 7d6f3457786f44758f1e2e9fcd1aa0837d0392cf2358fc966d93a666f81b7d03
+ sha256sums = e716a20a03b5c6560e7e9eeed1f656cbda3bfd1dafdfd26c8268bd1f00c5f554
+ sha256sums = 2f363dfdd53a54dd472edaf1e78252aa1270061d5b4448b1259b6f351c3dfd28
+
+pkgname = gemcraft1
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7bdbafe25911
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: vn158 <vn158 at seznam dot cz>
+
+pkgname=gemcraft1
+pkgver=1.111A
+pkgrel=1
+pkgdesc="Create and combine magic gems, put them into your towers and banish the monsters back to hell!"
+arch=('i686' 'x86_64')
+url="http://armorgames.com/play/1716/gemcraft"
+license=('custom')
+depends=("flashplayer-standalone")
+makedepends=('imagemagick')
+#source=("http://cache.armorgames.com/files/games/gemcraft-1716.swf" $pkgname)
+source=(http://gameinabottle.com/games/${pkgname}.swf http://gameinabottle.com/favicon.ico ${pkgname} ${pkgname}.desktop)
+
+md5sums=('4ae0f6369520686ae1e8433ebe564170'
+ '14f045b8d2a7d75de7cdb27dd4e9d6cd'
+ 'cade4ab4245725f2148b72326e550d7a'
+ '5c2f2f548be56b4b97d4eda201a2f833')
+sha256sums=('b7773ff1118aae4c36352e9d67e9430e36545b4255c5a3105ecfeef4957369ec'
+ '7d6f3457786f44758f1e2e9fcd1aa0837d0392cf2358fc966d93a666f81b7d03'
+ 'e716a20a03b5c6560e7e9eeed1f656cbda3bfd1dafdfd26c8268bd1f00c5f554'
+ '2f363dfdd53a54dd472edaf1e78252aa1270061d5b4448b1259b6f351c3dfd28')
+
+options=(!strip)
+
+build () {
+ convert favicon.ico ${pkgname}.png
+}
+
+package() {
+ #if path contains armorgames.com extra features are allowed, it doesn't work in 1.11
+ install -d "${pkgdir}"/usr/{bin,share/${pkgname}/armorgames.com}
+ install -d "${pkgdir}"/usr/share/applications
+ install -m644 ${pkgname}.swf "${pkgdir}"/usr/share/${pkgname}/armorgames.com
+ install -m644 ${pkgname}.png "${pkgdir}"/usr/share/${pkgname}/armorgames.com
+ install -m644 ${pkgname}.desktop "${pkgdir}"/usr/share/applications
+
+ install -m755 ${pkgname} "${pkgdir}"/usr/bin
+}
diff --git a/gemcraft1 b/gemcraft1
new file mode 100755
index 000000000000..82acff74bc30
--- /dev/null
+++ b/gemcraft1
@@ -0,0 +1,2 @@
+#!/bin/bash
+flashplayer /usr/share/gemcraft1/armorgames.com/gemcraft1.swf
diff --git a/gemcraft1.desktop b/gemcraft1.desktop
new file mode 100644
index 000000000000..412027396c41
--- /dev/null
+++ b/gemcraft1.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=GemCraft chapter 1: The Forgotten
+GenericName=GemCraft chapter 1: The Forgotten
+Comment=
+Exec=/usr/bin/gemcraft1
+Icon=/usr/share/gemcraft1/armorgames.com/gemcraft1.png
+StartupNotify=true
+Terminal=false
+Type=Application
+Categories=Application;Game