summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKirill Isakov2023-11-05 19:46:04 +0600
committerKirill Isakov2023-11-05 19:46:04 +0600
commiteddae1ce96f9954267e7aff7a6475030cf760b3e (patch)
treecb507a16c566e012fd414e48c1b22dd930c26508
parent72df7319e96253c1bb762ea8c0e897e8ddf9e605 (diff)
downloadaur-eddae1ce96f9954267e7aff7a6475030cf760b3e.tar.gz
upgpkg: gemget 1.9.0-1
upstream release
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD44
3 files changed, 39 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index df704025697d..278fbde78648 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = gemget
pkgdesc = Command line downloader for the Gemini protocol
- pkgver = 1.8.0
+ pkgver = 1.9.0
pkgrel = 1
- url = https://github.com/makeworld-the-better-one/gemget
+ url = https://github.com/makew0rld/gemget
arch = x86_64
license = MIT
makedepends = go
makedepends = git
- source = gemget-1.8.0.tar.gz::https://github.com/makeworld-the-better-one/gemget/archive/v1.8.0.tar.gz
- sha256sums = 52578dfc33c0275d71658d6afc0e0d91b3734032a6ed5b760d2695001b178c5a
+ source = git+https://github.com/makew0rld/gemget.git#tag=v1.9.0
+ sha256sums = SKIP
pkgname = gemget
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6f49f60bbeb3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+/*
+!/.gitignore
+!/PKGBUILD
+!/.SRCINFO
+
diff --git a/PKGBUILD b/PKGBUILD
index 799b6bb50bb1..7950e26834f2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,45 @@
-# Maintainer: dalz <aur @t alsd d0t eu>
+# Maintainer: tarball <bootctl@gmail.com>
+# Contributor: dalz <aur @t alsd d0t eu>
+
pkgname=gemget
-pkgver=1.8.0
-_commit=b32c6f861544e06c162320a56430dc31d35fd774
+pkgver=1.9.0
pkgrel=1
pkgdesc='Command line downloader for the Gemini protocol'
arch=('x86_64')
-url='https://github.com/makeworld-the-better-one/gemget'
+url='https://github.com/makew0rld/gemget'
license=('MIT')
makedepends=('go' 'git')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/makeworld-the-better-one/gemget/archive/v$pkgver.tar.gz")
-sha256sums=('52578dfc33c0275d71658d6afc0e0d91b3734032a6ed5b760d2695001b178c5a')
+source=(git+$url.git#tag=v$pkgver)
+sha256sums=('SKIP')
prepare() {
- cd "$pkgname-$pkgver"
- sed -i '/^GIT[VC]/d' Makefile
+ cd $pkgname
+ go mod download
}
build() {
- cd "$pkgname-$pkgver"
- GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw" \
- make VERSION="$pkgver" COMMIT="$_commit" BUILDER=gemget-AUR
+ cd $pkgname
+ GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw" \
+ make BUILDER=gemget-AUR
+}
+
+check() {
+ cd $pkgname
+
+ # verify version
+ diff \
+ <(./gemget --version) \
+ <(
+ cat <<EOF
+$pkgname v$pkgver
+Commit: $(git rev-parse HEAD)
+Built by: gemget-AUR
+EOF
+ )
}
package() {
- cd "$pkgname-$pkgver"
- install -D gemget "$pkgdir/usr/bin/gemget"
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd $pkgname
+ install -D gemget "$pkgdir/usr/bin/gemget"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}