summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHyacinthe Cartiaux2020-01-06 14:37:38 +0100
committerHyacinthe Cartiaux2020-01-06 14:37:50 +0100
commit7253ba35ab33271074c2e74a8f1115d941e1cbfb (patch)
treee5c261b303b0f4b393cb1d357e84149336c4d996
parentced07d993a73905ef0635d6ff8553106812bc197 (diff)
downloadaur-7253ba35ab33271074c2e74a8f1115d941e1cbfb.tar.gz
Update to 1.17-3
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD10
3 files changed, 12 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 40ecbd6a2db6..5a64ca07f5b6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,15 @@
-# Generated by mksrcinfo v8
-# Mon Oct 24 19:51:38 UTC 2016
pkgbase = genders
pkgdesc = Static cluster configuration database used for cluster configuration management.
- pkgver = 1.23
+ pkgver = 1.27.3
pkgrel = 1
url = https://computing.llnl.gov/linux/genders.html
arch = x86_64
arch = i686
license = GPL
options = !makeflags
- source = https://github.com/chaos/genders/archive/genders-1-23-1.tar.gz
+ source = https://github.com/chaos/genders/archive/genders-1-27-3.tar.gz
source = 624078.patch
- sha256sums = f165b6d6082a178145ff9e588abc011a53a8b67995125c1c1dc8363cdebbdd2e
+ sha256sums = c176045a7dd125313d44abcb7968ded61826028fe906028a2967442426229894
sha256sums = 7bd0e8bbf2e29ef00ee2387a1dd964cda841bc8995db85cf97b73c4dd766e699
pkgname = genders
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b20752a93bec
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.gz
+*.tar.xz
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
index 014b6e723344..77ac5a63ec85 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,21 @@
# Maintainer: Hyacinthe Cartiaux <hyacinthe.cartiaux@free.fr>
# Contributor: snafu <regflx@web.de>
pkgname=genders
-pkgver=1.23
+pkgver=1.27.3
pkgrel=1
pkgdesc="Static cluster configuration database used for cluster configuration management."
arch=('x86_64' 'i686')
url='https://computing.llnl.gov/linux/genders.html'
license=('GPL')
-source=("https://github.com/chaos/${pkgname}/archive/${pkgname}-${pkgver/./-}-1.tar.gz"
+source=("https://github.com/chaos/${pkgname}/archive/${pkgname}-${pkgver//./-}.tar.gz"
'624078.patch')
-sha256sums=('f165b6d6082a178145ff9e588abc011a53a8b67995125c1c1dc8363cdebbdd2e'
+sha256sums=('c176045a7dd125313d44abcb7968ded61826028fe906028a2967442426229894'
'7bd0e8bbf2e29ef00ee2387a1dd964cda841bc8995db85cf97b73c4dd766e699')
options=('!makeflags')
build() {
- cd "$srcdir/$pkgname-$pkgname-${pkgver/./-}-1"
+ cd "$srcdir/$pkgname-$pkgname-${pkgver//./-}"
patch -p1 < ../624078.patch
# export CPPFLAGS="-I/usr/lib/jvm/default/include -I/usr/lib/jvm/default/include/linux ${CPPFLAGS}"
./configure --prefix=/usr \
@@ -26,7 +26,7 @@ build() {
}
package() {
- cd "$srcdir/$pkgname-$pkgname-${pkgver/./-}-1"
+ cd "$srcdir/$pkgname-$pkgname-${pkgver//./-}"
make DESTDIR="$pkgdir/" install
}