summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVinicius Correa2019-07-18 10:43:26 -0300
committerVinicius Correa2019-07-18 10:43:26 -0300
commita0fac71431cb5a7b9d87517ab8dbd3b6623717b9 (patch)
tree0002d63751cc9620b43277edac867630717276f6
parent6bdca06d2234e6bf0c68ec61443d94ee2239faeb (diff)
downloadaur-a0fac71431cb5a7b9d87517ab8dbd3b6623717b9.tar.gz
added strip option
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD6
2 files changed, 4 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a5427163bdf8..19ba03dc9151 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,6 +6,7 @@ pkgbase = gendev
arch = any
license = BSD
depends = texinfo
+ options = !strip
source = https://github.com/kubilus1/gendev/releases/download/0.3.2/gendev_0.3.2.txz
md5sums = bee00fcef94169a82cba3c6b6c415777
diff --git a/PKGBUILD b/PKGBUILD
index cdce20349bf5..03b607f77a1b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,13 +7,13 @@ arch=('any')
url="https://github.com/kubilus1/${pkgname}"
license=('BSD')
depends=('texinfo')
+options=(!strip)
makedepends=('')
optdepends=('')
source=("https://github.com/kubilus1/gendev/releases/download/0.3.2/${pkgname}_${pkgver}.txz")
md5sums=('bee00fcef94169a82cba3c6b6c415777')
package() {
- install -d "${pkgdir}/opt/${pkgname}"
-
- cp -r "${srcdir}/opt/${pkgname}/"* "${pkgdir}/opt/${pkgname}" -R
+ install -dm755 "${pkgdir}/opt"
+ cp -r "${srcdir}/opt/${pkgname}" "${pkgdir}/opt/${pkgname}"
}