summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorABelliqueux2022-02-07 13:24:56 +0100
committerABelliqueux2022-02-07 13:24:56 +0100
commitcda8528c0ac3e15b654a7389b572438946335f41 (patch)
tree6ae0f5e567cbc10f2368ea25ca66661e59778bef
parent0d7754131426d57d0a242b2b6b4d9319b76253e0 (diff)
downloadaur-cda8528c0ac3e15b654a7389b572438946335f41.tar.gz
Update to 0.7.1, use liblto.so
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
-rw-r--r--liblto.patch12
3 files changed, 34 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6b568668ae99..64a04f2dc47c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
pkgbase = gendev
pkgdesc = Genesis development environment for Linux
- pkgver = 0.4.0
- pkgrel = 2
+ pkgver = 0.7.1
+ pkgrel = 1
url = https://github.com/kubilus1/gendev
arch = any
license = BSD
depends = texinfo
depends = jdk8-openjdk
+ depends = llvm-libs
options = !strip
- source = https://github.com/kubilus1/gendev/releases/download/0.4.0/gendev_0.4.0.txz
- md5sums = 37e61b25baa4229aa6b6c3d79d7b7953
-
-pkgname = gendev
+ source = https://github.com/kubilus1/gendev/releases/download/0.7.1/gendev_0.7.1.txz
+ source = liblto.patch
+ md5sums = 08f79f377570871899472ef4503382d3
+ md5sums = 68a2b31d51b80cb009b10443f527c2ba
+pkgname = gendev \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index a80ac07558e6..c71e23a25d4f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,23 @@
-# Maintainer: Vinicius Correa <vinicius dot correa at zoho dot com>
+# Maintainer: Arthus Belliqueux <contact at arthus dot net>
+# Contributor: Vinicius Correa <vinicius dot correa at zoho dot com>
pkgname=gendev
-pkgver=0.4.0
-pkgrel=2
+pkgver=0.7.1
+pkgrel=1
pkgdesc="Genesis development environment for Linux"
arch=('any')
url="https://github.com/kubilus1/${pkgname}"
license=('BSD')
-depends=('texinfo' 'jdk8-openjdk')
+depends=('texinfo' 'jdk8-openjdk' 'llvm-libs')
options=(!strip)
-makedepends=('')
-optdepends=('')
-source=("https://github.com/kubilus1/gendev/releases/download/${pkgver}/${pkgname}_${pkgver}.txz")
-md5sums=('37e61b25baa4229aa6b6c3d79d7b7953')
+makedepends=()
+optdepends=()
+source=("https://github.com/kubilus1/gendev/releases/download/${pkgver}/${pkgname}_${pkgver}.txz" "liblto.patch")
+md5sums=('08f79f377570871899472ef4503382d3'
+ '68a2b31d51b80cb009b10443f527c2ba')
+
+prepare() {
+ patch --binary --strip=1 --input=liblto.patch
+}
package() {
install -dm755 "${pkgdir}/opt"
diff --git a/liblto.patch b/liblto.patch
new file mode 100644
index 000000000000..81edc1b74c7f
--- /dev/null
+++ b/liblto.patch
@@ -0,0 +1,12 @@
+diff --color --unified --recursive --text src/opt/gendev/sgdk/mkfiles/makefile.gen src/opt/gendev/sgdk/mkfiles/makefile.gen
+--- src/opt/gendev/sgdk/mkfiles/makefile.gen 2021-06-05 21:11:02.000000000 +0200
++++ src/opt/gendev/sgdk/mkfiles/makefile.gen 2022-02-07 12:53:16.737498088 +0100
+@@ -147,7 +147,7 @@
+ $(SIZEBND) out/rom.bin -sizealign 131072
+
+ out/symbol.txt: out/rom.out
+- $(NM) --plugin=liblto_plugin-0.dll -n out/rom.out > out/symbol.txt
++ $(NM) --plugin=libLTO.so -n out/rom.out > out/symbol.txt
+
+ out/rom.out: out/sega.o out/cmd_ $(LIBMD)
+ $(CC) -B$(BIN) -n -T $(GDK)/md.ld -nostdlib out/sega.o @out/cmd_ $(LIBMD) $(LIB)/libgcc.a -o out/rom.out -Wl,--gc-sections \ No newline at end of file